Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Forums Oro Community Composer create project question

This topic contains 3 replies, has 2 voices, and was last updated by  o.z.muhsin 6 months, 4 weeks ago.

  • Creator
    Topic
  • #37554

    o.z.muhsin
    Participant

    I was trying to test some beta of 3.1.xxx in with env of php 7.1.23.So what I do is:

    The first thing pops up is Installation request for sebastian/phpcpd dev-master#cff7f36c2ae89d59987de25d14fd41a72dd4a703 as 3.1.0 -> satisfiable by sebastian/phpcpd[dev-master].
    …. googling i see https://github.com/oroinc/platform-application/pull/16#issuecomment-363664492…giving me a feeling these are known issues.

    I am even lost as that version (cff7f36c2ae89d59987de25d14fd41a72dd4a703 as 3.1.0) is not to be found in the composer.json :D
    Any idea on this ? Not so sure why but I assumed that composer create-project would do the trick, but eventually it does not work and yes I am aware of the docs && info (https://oroinc.com/b2b-ecommerce/doc/current/install-upgrade/installation-quick-start-dev/commerce-crm#install-composer).

    Many thanks.
    Omar

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #37555
    Michael
    Michael
    Keymaster

    oro/commerce is just a portion of what comprizes an OroCommerce application.
    The oro/commerce package description on packagist says – “This package requires an application to run it. Please check the installation instructions in orocommerce-application repository

    PS. Same like with “composer create-project symfony/symfony” will install just a package out of context, and with a lot of dev-master dependencies, because the correct command to install a Symfony application is “composer create-project symfony/framework-standard-edition“.

    #37556
    Michael
    Michael
    Keymaster

    PPS. Btw, for “composer create-project oro/commerce-crm-application:3.1.0-beta” to work you will have to configure the correct package repositories first, by probably running something like “composer config repositories.repo-name type url” for each repository.

    #37559

    o.z.muhsin
    Participant

    Thanks this explains where the “cff7f36c2ae89d59987de25d14fd41a72dd4a703 as 3.1.0” comes from.

    P:S
    Is it an idea may be to add another entry in packagist e.g (oro/commerce-crm-application -> linking it to https://github.com/oroinc/orocommerce-application.git) ?

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No