OroPlatform Forums

Covering OroPlatform topics, including community updates and company announcements.

This topic contains 16 replies, has 2 voices, and was last updated by  bebesbrasil 5 years, 8 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #35128

    bebesbrasil
    Participant

    Hi Guys!

    I am trying to install OroCRM for hours. Unfortunately it’s not working. :-(

    See the commands performed for installation. Typed exactly as it is below in the same order:

    Apparently attend all mandatory requirements. see:
    *Unfortunately I could not install Node.js for server limitation.
    Server details

    PHP Command Line Interface
    – This is available via your ssh user.
    php-cli -v
    PHP 5.3.24 (cli) (built: Apr 24 2013 11:24:37)
    Copyright (c) 1997-2013 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies
    with the ionCube PHP Loader v4.5.3, Copyright (c) 2002-2014, by ionCube Ltd.

    PHP EXTENSIONS:GD 2.0 and above
    – The GD Version is 2.1.0 compatible as shown at http://www.bebesbrasil.com.br/nexinfo.php

    json
    – installed using version 1.2.1

    Mcrypt
    – mcrypt is installed and using 2.5.8

    PCRE 8.0 and above
    – PCRE (Perl Compatible Regular Expressions) Support is enabled and using version 8.32

    SimpleXML
    – SimpleXML is enabled

    Tokenizer
    – tokenizer is enabled

    Could someone tell me please what am I doing wrong?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Author
    Replies
  • #35129
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    Hello, bebesbrasil.

    – symfony/icu v1.2.2 requires lib-icu >=4.4 -> the requested linked library icu has the wrong version installed or is missing from your system, make sure to have the extension providing it.

    You should check whether lib icu is installed on your environment, and if not – install it. You can check that in following way:

    #35130

    bebesbrasil
    Participant

    Hello, Yevhen Shyshkin. Thanks for your help.

    I typed the command in my terminal and received the following:

    This means that I have to upgrade to a version greater than or equal to 4.4? If so, could you tell me what command should I use to do this update?

    #35131
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    > This means that I have to upgrade to a version greater than or equal to 4.4?
    Yes.

    > what command should I use to do this update?
    It depends on your environment and package manager, see manuals for your linux distribution.

    #35132

    bebesbrasil
    Participant

    Right. Many thanks for the help!

    #35133

    bebesbrasil
    Participant

    Hello. I was able to continue the installation, but now I see this error on the browser screen.

    Clear cache before database initialization Done
    Drop current schema Done
    Clear entities cache Done
    Clear extended entities data Done
    Schema update Failed
    Load workflow definitions Skipped
    Load processes configuration Skipped
    Load fixtures Skipped

    I honestly have no idea how to solve this. :-(

    #35134
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    Please, put here content of file app/logs/oro_install.log – it contains detailed installation log, so there might be a reason of installtion failure.

    #35135

    bebesbrasil
    Participant

    Yes, here it is.

    #35136
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    Please, check this error, look’s like modification in Kernel:PHP Parse error: syntax error, unexpected '[' in /chroot/home/bebesbra/bebesbrasil.com.br/html/crm/platform-application/vendor/oro/platform/src/Oro/Bundle/DistributionBundle/OroKernel.php on line 284

    After that, please, recreate your DB and try to install application again.

    #35137

    bebesbrasil
    Participant

    Sorry, did not quite understand what I do. I am beginner in this. I looked at the OroKernel.php file but it seems all right.

    #35138
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    Oh, I see… You have PHP 5.3.24, and Oro requires >= 5.4.9. Please, install newer version and try again.

    #35139

    bebesbrasil
    Participant

    Yeah … I’m actually using PHP 5.4. Already recreated the database but the error continues.

    #35140

    bebesbrasil
    Participant
    #35141
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    According to your previous php CLI output you have php 5.3:

    But phpinfo output tells that you have 5.4:

    Maybe you have different php versions for different virtual hosts?

    About error – is it the same? Because previous error appears only on 5.3 because of short array syntax that was introduced only on 5.4.

    #35142

    bebesbrasil
    Participant

    Hi, Yevhen Shyshkin.
    I upgraded PHP to version on my hosting. see:

    Recreated the database and redid the installation. But the same error continues, both on the browser page and in the log file.

    #35143
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    Please, check php version via phpinfo() via browser.

Viewing 15 replies - 1 through 15 (of 16 total)

The forum ‘OroPlatform – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No