OroPlatform Forums

Covering OroPlatform topics, including community updates and company announcements.

Forums Forums OroPlatform OroPlatform – Installation/Technical Issues or Problems composer.json requires wrong composer/composer version

This topic contains 2 replies, has 2 voices, and was last updated by  babr79 5 years, 4 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #35176

    babr79
    Participant

    Hello!
    I have a problem while do composer install.

    In 1.7.0 , 1.6.3, and master version of oro/platform composer.json – “composer/composer: 1.0.0-p1” required.
    But there no such version in composer/composer packagist (https://packagist.org/packages/composer/composer ) or composer/composer github (https://github.com/composer/composer )

    So, “composer install” cannot finish work, and told:
    [18:29:26][Step 3/7] Problem 1
    [18:29:26][Step 3/7] – Installation request for oro/platform 1.x-dev -> satisfiable by oro/platform[1.x-dev].
    [18:29:26][Step 3/7] – oro/platform 1.x-dev requires composer/composer 1.0.0-p1 -> no matching package found.

    [18:29:26][Step 3/7] Problem 2
    [18:29:26][Step 3/7] – oro/platform 1.x-dev requires composer/composer 1.0.0-p1 -> no matching package found.
    [18:29:26][Step 3/7] – oro/crm 1.x-dev requires oro/platform 1.x-dev -> satisfiable by oro/platform[1.x-dev].
    [18:29:26][Step 3/7] – Installation request for oro/crm 1.x-dev -> satisfiable by oro/crm[1.x-dev].
    [18:29:26][Step 3/7]

    Please fix this.

    Best Regards, Vassiliy

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #35177

    Hello!
    We forked composer bundle and created patched version. To use it please add to composer.json
    "repositories": [
    {
    "type": "composer",
    "url": "http://packagist.orocrm.com"
    }
    ],

    Original composer bundle does not work with symfony 2.3

    #35178

    babr79
    Participant

    Thank you very much! :)

Viewing 2 replies - 1 through 2 (of 2 total)

The forum ‘OroPlatform – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No