OroPlatform Forums

Covering OroPlatform topics, including community updates and company announcements.

Forums Forums OroPlatform OroPlatform – Installation/Technical Issues or Problems Fatal error: Class 'Oro\Bundle\AttachmentBundle\OroAttachmentBundle' not found

This topic contains 3 replies, has 2 voices, and was last updated by  mbyta 8 years, 1 month ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #34940


    Hi everyone,

    I’m currently trying to install oro-platform on my local machine.
    I’m following the instructions here: http://oroinc.com/orocrm/doc/current/book/installation

    On the “Configure the Database” section, when I run this command, “php app/console doctrine:database:create”, I get this error:

    Fatal error: Class ‘Oro\Bundle\AttachmentBundle\OroAttachmentBundle’ not found

    Where can I get this bundle please ? Is my composer file out of date ?

    NB: I checked out at the tag 1.2.0. I’m at the revision 574d63fe69bddd6df922f83f36e59dedcdf15e67

    My Configuration:
    Windows 7
    – Apache 2.2.4
    – PHP 5.4.12
    – MySQL 5.6.12

    Thanks in advance

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
  • #34941


    Try updating composer:

    php composer.phar update

    Then re-run your database:create command

    ~Coding my life away~



    Hi hemham914, thanks for your reply.

    I had a previous problem before when trying to install the app “FileLoaderLoadException: Cannot import resource config.yml from config_dev.yml” and I posted the problem on the forum.
    The solution I was given was to update the project with the command “php composer.phar update –prefer-dist“.
    I did and this problem was solved but then there’s this new problem of unknown bundle.
    But I’ll once again update composer just in case.



    Ok so now I know what was the problem:
    I was on master when I ran the composer.phar update command, and then I checked out on 1.2.0. That’s when I got the problem.
    I should’ve first checked out on 1.2.0 and then run the composer command.

Viewing 3 replies - 1 through 3 (of 3 total)

The forum ‘OroPlatform – Installation/Technical Issues or Problems’ is closed to new topics and replies.

Back to top

You will be redirected to [title]. Would you like to continue?

Yes No

You will be redirected to [title]. Would you like to continue?

Yes No