OroPlatform Forums

Covering OroPlatform topics, including community updates and company announcements.

Forums Forums OroPlatform OroPlatform – Security ASSIGN permission for entity

This topic contains 2 replies, has 2 voices, and was last updated by Dmytro Vasylenko Dmytro Vasylenko 6 years ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #35472
    Dmytro Vasylenko
    Dmytro Vasylenko
    Participant

    Hi,

    I’m trying to add new entity. Requirement is that this entity should have separate permission for ASSIGN.

    Annotation for this entity looks like

    also tried this

    Manually placing there ASSIGN does not help either.

    What are requirements to make this happen ?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #35473

    Yurii Muratov
    Participant

    Hi.
    Do You have this entity in entities list then You edit some role?
    And if this enity exists in list, what permissions there are for this entity?

    Additionaly, try to run php app/console oro:entity-config:update command.

    #35474
    Dmytro Vasylenko
    Dmytro Vasylenko
    Participant

    hi,

    Yes, i’ve it. I see all permissions (VIEW, CREATE, EDIT, DELETE) except ASSIGN. That column is empty for mine entity.

    Tried to run that commend, without it as i understood entity should not appear at the list at all.

Viewing 2 replies - 1 through 2 (of 2 total)

The forum ‘OroPlatform – Security’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No