OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums OroCommerce AWS – Orocommerce Installation

This topic contains 6 replies, has 3 voices, and was last updated by  snb-me 4 days, 23 hours ago.

  • Creator
    Topic
  • #38825

    snb-me
    Participant

    Hello,

    I installed orocommerce via the aws marketplace, it works fine whilst using the IP address. Once I connect it to my domain and redirect namesavers to the IP, the website starts showing box icons instead of the original icons. Everything else works fine, but icon pictures become boxes.

    I tried using php bin/console server:plank

    however, I get an error message :

    bash: php command not found

    I see that php is not installed on the server when a launch an instance with the AWS orocommerce.

    I tried installing PHP onto the server after launching it, but that makes the website give http error – server cannot load.

    Not sure how to fix this. Can oro only be used after a manual installation?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #38827
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi,

    To prevent redirect to IP address, you must set the website URL to your domain at the back-office.

    The command name is “php bin/console server:clank”, but it was used in an older versions of OroCommerce.

    If you are using 3.1 or a newer version, the command name is
    php bin/console gos:websocket:server --env=prod
    See Configure and run required background processes.

    #38829

    dubrsl
    Participant

    Hi,

    The server can’t work without php. So it’s already installed. You can check it if run

    Php built as scl (Software collection), so you should enable it before use. Please read
    https://oroinc.com/orocrm/doc/current/install-upgrade/installation-quick-start-dev/crm-ee#install-oro-application
    And run

    before run php bin/console

    #38830

    snb-me
    Participant

    Thanks, I see i need to add configuration to Supervisord file as mentioned in the installation guide.
    HOwever, I do not have the /etc/supervisord.conf file in my server at etc folder.

    #38831

    snb-me
    Participant

    Thank you dubrsl & andrey,

    PHP works now, however it gives me the error:

    Could not bind to tcp://0.0.0.1:8080: Address already in use

    I tried with 0.0.0.0:8080 as well and i get the same error.

    What parameterys.yml websocket configuration should i do on an AWS Centos instance such that it works?

    #38833

    dubrsl
    Participant

    > I do not have the /etc/supervisord.conf file in my server at etc folder.
    There is no supervisord. CentOS-7 has systemd and this installation use it.
    You can run

    for get status of all oro services.

    #38834

    snb-me
    Participant

    Thanks Dubrsl for your prompt response. Its very helpful.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No