Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Forums OroCommerce Blank Pages after Home Page Load successful

This topic contains 2 replies, has 2 voices, and was last updated by  Jack 1 year, 5 months ago.

  • Creator
  • #31664


    Not sure what’s happening – this is a new OroCommerce install – I clear the prod cache and the home page will load perfectly fine. Then, if I click on any link on the homepage – it will go to that page and the browser load will spin for a little while and then stop on a blank page. Going back to the home page will now result in a blank page. If I clear the cache again, the home page will load, but with the same issues on further loading.

    I do notice that when the home page loads, the title of the Home Page is %status% which I found odd.

    Any help with troubleshooting this would be appreciated as there’s nothing in any of the logs to indicate any issues with page load etc.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
  • #31665



    Can you provide us prod.log? To do so, please:
    1. Remove file app/logs/prod.log
    2. Enter Homepage
    3. Click any link on home page
    4. When you’ve got blank page, copy content of app/logs/prod.log and put it here. If the content of this file would be to big, please put it on some external site, ie:



    [SOLVED] Two issues that combined to create these odd issues:

    1. When running cache:clear and cache:warmup the permissions were changed after execution of these commands to the user running the command. Double-check these permissions each time!

    2. There are = 2 = nesting options in php, these both must be changed to 256 or more.
    max_input_nesting_level = 256 (usually in php.ini)
    xdebug.max_nesting_level = 256 (usually in a separate file under php.d, with x-debug in the filename)

    I only had the option set in php.ini, and it gave the issues described.

    Once these three things are done, and the cache flushed AFTER they are set (don’t forget to restart apache) the pages started operating normally.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No