OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums OroCommerce Can I use Symfony's internal Webserver for Development?

This topic contains 2 replies, has 2 voices, and was last updated by  Frank 3 weeks, 1 day ago.

  • Creator
    Topic
  • #40859

    Frank
    Participant

    Hi there,

    I use orocommerce 3.1.9. For developmental purposes it would be great to use Symfony’s internal web-server:

    $ oroapp> symfony server:ca:install
    $ oroapp/public> symfony serve
    Nov 11 14:59:41 |DEBUG| PHP Using PHP version 7.1.30 (from .php-version in current directory (/usr/share/nginx/html/oroapp319/public/.php-version))
    Nov 11 14:59:41 |INFO | PHP listening path=”/opt/remi/php71/root/usr/bin/php-cgi” php=”7.1.30″ port=37163
    Nov 11 14:59:41 |DEBUG| PHP started
    [OK] Web server listening on https://127.0.0.1:8000 (PHP CGI 7.1.30)

    Calling https://localhost:8000 in my Browser results in an error:

    In DriverManager.php line 181:
    (1/1) ClassNotFoundException
    Attempted to load class “PDO” from the global namespace.
    Did you forget a “use” statement?

    And the error-log says:
    Nov 11 15:01:51 |ERROR| SERVER GET (500) / ip=”127.0.0.1″

    Would it be possible to run orocommerce with symfony’s local Webserver , and if yes – how?

    Thanks a lot
    Frank

    PS: For me it is an easy way (1) to use https://, and (2) to switch php-versions (7.1 -> 7.2 -> 7.1 …), which is easy with this webserver.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #40861
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi Frank,

    I use the Symfony server every day for about a year without significant issues. Please make sure you have configured the development environment correctly.
    An error ‘Attempted to load class “PDO” from the global namespace.’ means you haven’t installed the required PDO extension for the PHP, but probably you have done it. The server can use a different version of a PHP than you used before installing the server. Usually, the built-in PHP that comes with the OS goes without PDO extension.
    To see the list of installed PHP versions you can run symfony local:php:list
    Then you can switch the version in your .php-version file to the exact one that you used before.

    If the used PHP version is correct, you have to install additionally the PDO extension, like php-mysql.

    #40890

    Frank
    Participant

    Hi Andrey,

    thanks for your answer. Good to know, that symfony’s inbuilt web-server works for orocommerce. I will make use of it from now.

    You are right, my problem was caused by an misconfigured PDO-extension. I removed the several old php-versions, and after reinstalling php 7.1.30 it works fine.

    Thanks a lot. It was realy helpful.

    Kind regards
    Frank

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No