OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums OroCommerce Fatal error after installation Oro Commerce

This topic contains 3 replies, has 2 voices, and was last updated by Andrey Yatsenko Andrey Yatsenko 3 months ago.

  • Creator
    Topic
  • #38601
    juandres.lazaro
    juandres.lazaro
    Participant

    After installation there is the message:
    Fatal error: Uncaught Symfony\Component\Debug\Exception\UndefinedFunctionException: Attempted to call function “openssl_cipher_iv_length” from namespace “ass\XmlSecurity\Key”. in C:\wamp64\www\oro\orocommerce\vendor\ass\xmlsecurity\src\ass\XmlSecurity\Key\Block.php on line 157

    I followed the installation guide with the composer and git. All of them generated the same fault. Which way should I go to find the source of the problem?

    Thanks any help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #38615
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi Juandres,

    Please check system requirements.
    You must enable openssl php extension for proper work.

    #38630
    juandres.lazaro
    juandres.lazaro
    Participant

    Thanks Andrey Yatsenko

    The openssl php extension is enable in php.ini (extension=openssl)

    But in php_info() I have this:

    Phar
    Phar: PHP Archive support enabled
    Phar EXT version 2.0.2
    Phar API version 1.1.1
    SVN revision $Id: f1155e62742ca367e521a3e412667d8ee34eead9 $
    Phar-based phar archives enabled
    Tar-based phar archives enabled
    ZIP-based phar archives enabled
    gzip compression enabled
    bzip2 compression enabled
    OpenSSL support disabled (install ext/openssl)

    I use wamp 3.1.4: php 7.2.16 and apache 2.4.16.

    I appreciate if you have any search reference. I’ll keep trying.

    #38631
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Wamp usually comes with openssl included, this is strange.
    in php_info output you can find the loaded php.ini files, it is possible that you have multiple files and enabled an extension in the wrong one.

    Also, configuration for php-fpm and php-cli can be different, so make sure openssl is enabled for php-cli as well. you can find loaded php.ini file by running from CLIphp --ini
    to check that openssl is loaded in CLI, you can run php -m | grep openssl it should output openssl

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No