OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums OroCommerce how to update plugins in oro

This topic contains 9 replies, has 2 voices, and was last updated by Andrey Yatsenko Andrey Yatsenko 2 months, 2 weeks ago.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Author
    Replies
  • #40464
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    You could skip extension-version completely when installing an extension, in this case, the composer will choose the latest available version that compatible with the version of an installed application. So the command would be like this
    composer require <extension name> –prefer-dist –update-no-dev

    If you still want to know what versions are available, you can check it at https://satis.oroinc.com

    #40468

    jithin
    Participant

    Hi,

    Thanks you for the input.

    could you also give me the command to install the below plugin?

    Business Card Reader for OroCRM

    I tried below

    but got below error, seems like I entered the wrong extension name, how can I get the correct name?

    [InvalidArgumentException]
    Could not find a matching version of package oro/call-tracker-for-orocrm. Check the package spelling, your
    version constraint and that the package is available in a stability which matches your minimum-stability (d
    ev).

    require [–dev] [–prefer-source] [–prefer-dist] [–no-progress] [–no-suggest] [–no-update] [–no-scripts] [–update-no-dev] [–update-with-dependencies] [–update-with-all-dependencies] [–ignore-platform-reqs] [–prefer-stable] [–prefer-lowest] [–sort-packages] [-o|–optimize-autoloader] [-a|–classmap-authoritative] [–apcu-autoloader] [–] [<packages>]…

    Thanks

    #40469
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Business Card Reader for OroCRM

    This is not a plugin but an external application as I see.

    #40475

    jithin
    Participant

    Ok,

    Ho can I install the external packages?

    Thanks for helping on this.

    #40476
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    For the Business Card Reader go to the marketplace page, press “Get extension” and install it from google play or an app store by following the official guide.

    #40554

    jithin
    Participant

    Thanks

    are below plugins compatible with orocrm / orocommerce 4.0

    oro/commerce-authorizenet
    oro/commerce-paypal-express
    oro/google-tag-manager-bundle

    I am facing lot of dependency issues while installing these in orocommerce 4.0

    some of the error are given below
    ——————————–
    Problem 1
    – Installation request for oro/commerce-paypal-express ^3.1 -> satisfiable by oro/commerce-paypal-express[3.1.0, 3.1.x-dev].
    – Can only install one of: oro/platform-serialised-fields[4.0.0, 3.1.x-dev].
    – Can only install one of: oro/platform-serialised-fields[3.1.x-dev, 4.0.0].
    – Can only install one of: oro/platform-serialised-fields[3.1.x-dev, 4.0.0].
    – Conclusion: install oro/platform-serialised-fields 3.1.x-dev
    – Installation request for oro/platform-serialised-fields (locked at 4.0.0, required as 4.0.*) -> satisfiable by oro/platform-serialised-fields[4.0.0].

    ——————————–

    ——————————–

    Problem 1
    – Can only install one of: oro/commerce-crm[1.6.x-dev, 4.0.0].
    – Can only install one of: oro/commerce-crm[4.0.0, 1.6.x-dev].
    – Can only install one of: oro/commerce-crm[1.6.x-dev, 4.0.0].
    – oro/commerce-consents 1.6.8 requires oro/commerce-crm 1.6.* -> satisfiable by oro/commerce-crm[1.6.x-dev].
    – Installation request for oro/commerce-consents 1.6.8 -> satisfiable by oro/commerce-consents[1.6.8].
    – Installation request for oro/commerce-crm (locked at 4.0.0, required as 4.0.*) -> satisfiable by oro/commerce-crm[4.0.0].

    ——————————–

    #40557
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    are below plugins compatible with orocrm / orocommerce 4.0

    – oro/commerce-paypal-express – no
    – oro/commerce-authorizenet – yes
    – oro/google-tag-manager-bundle – yes

    #40561

    jithin
    Participant

    ok,

    One more plugin I want to install is

    oro/commerce-consents

    how can I check if a plugin is compatible with my oro version

    Thanks

    #40562
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    You could check available plugin versions at https://satis.oroinc.com

    oro/commerce-consents

    This plugin was integrated to core in a newest version and will not be released anymore.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No