OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums OroCommerce I can't export the products from my site

This topic contains 4 replies, has 3 voices, and was last updated by  Merlin 4 months ago.

  • Creator
    Topic
  • #39797

    Mauro Chojrin
    Participant

    I’m trying to export all the products in a particular category but every time I click on “Export Products” I get an email saying there are no products to be exported (Which is not true as I’m seeing quite a few on my screen).

    I tried to select all the products before clicking the button but it had no effect…

    What am I doing wrong?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #39871
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi Mauro,

    Looks like the issue is caused by the customization, because we can’t reproduce the case with “no products to be exported” on a clean installation.

    You should not that “Export Products” should always export all the available products and there is no way to limit the list with filters there.

    But if you want to export the filtered products list, we recommend using the “Export Grid” functionality that is not implemented for the product grid but is easy to add by following this documentation:
    https://github.com/oroinc/platform/blob/master/src/Oro/Bundle/DataGridBundle/Resources/doc/backend/extensions/export.md

    #39872
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    There is a related bug where you will get an empty exported file for any grid when there is no “English” localization available at the system.
    Please check the log file, it should have an error message if it is the case.

    Also, you can try to export any other grid and share the localization configuration with us to confirm it is the same or related bug. Thank you.

    #39885

    Mauro Chojrin
    Participant

    I’m affraid the error log is also empty :(

    Here’s the email I get:

    No products found for export.

    Export operation failed, 1 error(s) found. Error log

    But when I click on the link I’ll get a blank file (located at URI /admin/import_export/job-error-log/963268.log)… I tried to find it ssh’ing to the server but couldn’t locate it.

    #40136

    Merlin
    Participant

    +1

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No