OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums Forums OroCommerce oro:asset:install fails (timeout)

This topic contains 8 replies, has 3 voices, and was last updated by Niklas Niklas 8 months, 1 week ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #41254
    Niklas
    Niklas
    Participant

    We have some problems when we try to install our assets.
    Everytime we use the command “sudo php ./bin/console oro:assets:install –no-debug” (with or without sudo or debug) we get the following timeout error:

    [OK] All assets were successfully installed.

    Move “XXX/public/js/bowerassets” to “XXX/public/bundles/bowerassets”
    Move “XXX/public/js/npmassets” to “XXX/public/bundles/npmassets”
    Move “XXX/public/js/components” to “XXX/public/bundles/components”
    Installing npm dependencies.
    /usr/local/bin/npm
    –no-audit
    install
    Done.
    Building assets.
    ‘/usr/local/bin/node’ ‘vendor/oro/platform/build/node_modules/webpack/bin/webpack.js’ ‘–mode=production’ ‘–env.symfony=dev’ ‘–colors’

    In Process.php line 1330:

    The process “‘/usr/local/bin/node’ ‘vendor/oro/platform/build/node_modules/webpack/bin/webpack.js’ ‘–mode=production’ ‘–env.symfony=de
    v’ ‘–colors'” exceeded the timeout of 300 seconds.

    oro:assets:build [-w|–watch] [-i|–npm-install] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-e|–env ENV] [–no-debug] [–disabled-listeners DISABLED-LISTENERS] [–current-user CURRENT-USER] [–current-organization CURRENT-ORGANIZATION] [–] <command> [<theme>]

    In CommandExecutor.php line 214:

    The command terminated with an exit code: 1.

    Is there any way to increase the timeout limit? Somehow the install command succeed from time to time… so we were able to load our styles.scss changes. But now even with an empty styles.scss file we get the timeout. We even tried to disable all custom bundles!
    We would be grateful for any help!

    we are using OroCommerce 3.1.17

    best regards,
    Niklas

    • This topic was modified 8 months, 1 week ago by Niklas Niklas.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #41256

    HulTh
    Participant

    +1

    We have the same issue.

    • This reply was modified 8 months, 1 week ago by  HulTh.
    #41259
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    You can increase timeouts for npm install and webpack build commands with the configuration in config/config.yml file:
    https://github.com/oroinc/platform/blob/master/src/Oro/Bundle/AssetBundle/Resources/doc/index.md#build_timeout

    #41265

    HulTh
    Participant

    Thanks for reply. The increase works.

    Now i get this errors:

    • This reply was modified 8 months, 1 week ago by  HulTh.
    #41267
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Do you have this error during the upgrade or after some changes in your application code?

    #41268

    HulTh
    Participant

    After the Upgrade.

    #41273
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Please clarify, from what version do you upgrade an application?

    #41278
    Niklas
    Niklas
    Participant

    We did an upgrade from orocommerce 3.1.6 to 3.1.17

    #41279
    Niklas
    Niklas
    Participant

    Okay we have found our Problem.. we mistakenly included the default oro settings and variables like ‘bundles/orofrontend/default/scss/settings/global-settings.scss’ & – ‘bundles/orofrontend/default/scss/variables/page-content-config.scss’ in our assets.yml!

    That’s why it took so long to execute the oro:asset:install command and why apparently the correct paths to fonts and images were not found.

Viewing 8 replies - 1 through 8 (of 8 total)

The forum ‘OroCommerce’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No