OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums OroCommerce Orocommerce 3.1 unable to install

This topic contains 10 replies, has 3 voices, and was last updated by Andrey Yatsenko Andrey Yatsenko 1 month, 2 weeks ago.

  • Creator
    Topic
  • #38112

    Ingole Avinash
    Participant

    Hi this is Avinash
    I am not able to install where is the installation documentation and github link for cloning the code from github. can you share me github link for orocommerce 3.1 LTs version

    Thanks in Advance.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #38159
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi Avinash,

    Here all the links to installation
    https://oroinc.com/b2b-ecommerce/doc/current/install-upgrade

    We have multiple applications and few options to install.
    The simplest one is using Vagrant.

    #38164

    Ingole Avinash
    Participant

    Hi Andrey

    I think This is link you have provided for orocommerce 3.0.i want to install orocommerce 3.1 Lts version from scratch

    #38196
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    It was an error, we updated the documentation.
    Thank you for the report. You can try again.

    #38215

    Ingole Avinash
    Participant

    Hi Andrey
    Thank for assistance
    When i going to install 3.1 lts version i am getting following Errors
    can you please tell what i missed and how to fix it ?

    #38305
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    The main issue here, that the user used to run an installation has no permissions to create a folder.

    #38309

    Ingole Avinash
    Participant

    Thanks Andrey
    I resolved this issue by manually creating folder

    #40700

    abhishek.uct
    Participant

    I have the issue , i have not able to solve this

    In OroAssetsBuildCommand.php line 199:

    npm WARN deprecated istanbul@0.4.5: This module is no longer maintained, try this instead:
    npm WARN deprecated npm i nyc
    npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
    npm WARN deprecated circular-json@0.5.9: CircularJSON is in maintenance only, flatted is its successor.
    npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
    npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
    npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
    Unable to save binary /var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/vendor/linux-x64-64 : { Error: EACCES: permission denied, mkdir ‘/var/w
    ww/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/vendor’
    at Object.mkdirSync (fs.js:757:3)
    at sync (/var/www/html/oroapp/vendor/oro/platform/build/node_modules/mkdirp/index.js:71:13)
    at Function.sync (/var/www/html/oroapp/vendor/oro/platform/build/node_modules/mkdirp/index.js:77:24)
    at checkAndDownloadBinary (/var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/scripts/install.js:114:11)
    at Object.<anonymous> (/var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/scripts/install.js:157:1)
    at Module._compile (internal/modules/cjs/loader.js:778:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    at Module.load (internal/modules/cjs/loader.js:653:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    at Function.Module._load (internal/modules/cjs/loader.js:585:3)
    errno: -13,
    syscall: ‘mkdir’,
    code: ‘EACCES’,
    path:
    ‘/var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/vendor’ }
    gyp info it worked if it ends with ok
    gyp verb cli [ ‘/usr/bin/node’,
    gyp verb cli ‘/var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-gyp/bin/node-gyp.js’,
    gyp verb cli ‘rebuild’,
    gyp verb cli ‘–verbose’,
    gyp verb cli ‘–libsass_ext=’,
    gyp verb cli ‘–libsass_cflags=’,
    gyp verb cli ‘–libsass_ldflags=’,
    gyp verb cli ‘–libsass_library=’ ]
    gyp info using node-gyp@3.8.0
    gyp info using node@10.16.3 | linux | x64
    gyp verb command rebuild []
    gyp verb command clean []
    gyp verb clean removing “build” directory
    gyp verb command configure []
    gyp verb check python checking for Python executable “python2” in the PATH
    gyp verb which succeeded python2 /usr/bin/python2
    gyp verb check python version `/usr/bin/python2 -c “import sys; print “2.7.15
    gyp verb check python version .%s.%s” % sys.version_info[:3];”` returned: %j
    gyp verb get node dir no –target version specified, falling back to host node version: 10.16.3
    gyp verb command install [ ‘10.16.3’ ]
    gyp verb install input version string “10.16.3”
    gyp verb install installing version: 10.16.3
    gyp verb install –ensure was passed, so won’t reinstall if already installed
    gyp WARN EACCES user “root” does not have permission to access the dev dir “/root/.node-gyp/10.16.3”
    gyp WARN EACCES attempting to reinstall using temporary dev dir “/var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/.node-gyp”
    gyp verb tmpdir == cwd automatically will remove dev files after to save disk space
    gyp verb command install [ ‘–node_gyp_internal_noretry’, ‘10.16.3’ ]
    gyp verb install input version string “10.16.3”
    gyp verb install installing version: 10.16.3
    gyp verb install –ensure was passed, so won’t reinstall if already installed
    gyp verb install version not already installed, continuing with install 10.16.3
    gyp verb ensuring nodedir is created /var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/.node-gyp/10.16.3
    gyp WARN install got an error, rolling back install
    gyp verb command remove [ ‘10.16.3’ ]
    gyp verb remove using node-gyp dir: /var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/.node-gyp
    gyp verb remove removing target version: 10.16.3
    gyp verb remove removing development files for version: 10.16.3
    gyp WARN install got an error, rolling back install
    gyp verb command remove [ ‘10.16.3’ ]
    gyp verb remove using node-gyp dir: /var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/.node-gyp
    gyp verb remove removing target version: 10.16.3
    gyp verb remove removing development files for version: 10.16.3
    gyp ERR! configure error
    gyp ERR! stack Error: EACCES: permission denied, mkdir ‘/var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass/.node-gyp’
    gyp ERR! System Linux 5.0.0-1018-azure
    gyp ERR! command “/usr/bin/node” “/var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-gyp/bin/node-gyp.js” “rebuild” “–verbose” “–libsass_ext=” “–l
    ibsass_cflags=” “–libsass_ldflags=” “–libsass_library=”
    gyp ERR! cwd /var/www/html/oroapp/vendor/oro/platform/build/node_modules/node-sass
    gyp ERR! node -v v10.16.3
    gyp ERR! node-gyp -v v3.8.0
    gyp ERR! not ok
    Build failed with error code: 1
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {“os”:”darwin”,”arch”:”any”} (current: {“os”:”linux”,”arch”:”x64″})

    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! node-sass@4.12.0 postinstall: node scripts/build.js
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the node-sass@4.12.0 postinstall script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /root/.npm/_logs/2019-10-16T10_15_31_418Z-debug.log

    oro:assets:build [-w|–watch] [-i|–npm-install] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-e|–env ENV] [–no-debug] [–disabled-listeners DISABLED-LISTENERS] [–current-user CURRENT-USER] [–current-organization CURRENT-ORGANIZATION] [–] <command> [<theme>]

    In CommandExecutor.php line 208:

    The command terminated with an exit code: 1.

    oro:assets:build [-w|–watch] [-i|–npm-install] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-e|–env ENV] [–no-debug] [–disabled-listeners DISABLED-LISTENERS] [–current-user CURRENT-USER] [–current-organization CURRENT-ORGANIZATION] [–] <command> [<theme>]

    #40707
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    the error is related to the permissions. Make sure you are not using the root users, as there are issues with npm when using it.

    #40734

    abhishek.uct
    Participant

    Hi Andrey Yatsenko,
    Thanks for the reply,
    I am currently using the root user to install OroCommerce,
    So What should I use , Login as normal user and run the run install command with sudoer priveleges.

    Thanks

    #40745
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    sudo should not be used for the installation itself, only you need it for the environment configuration step, see
    https://doc.oroinc.com/backend/setup/dev-environment/manual-installation/commerce-ce/

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No