OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums Forums OroCommerce Owner notifiction email

This topic contains 16 replies, has 2 voices, and was last updated by  ramanburdak396 5 months, 4 weeks ago.

The forum will run in the read-only mode starting from March 1. Please head to StackOverflow for support.

  • Creator
    Topic
  • #40027

    ramanburdak396
    Participant

    can we set up a notification email for owner if customer submit this registration form?

    Where i can add multiple email address for owner notify when customer registration.

    Thanks

Viewing 15 replies - 1 through 15 (of 16 total)
  • Author
    Replies
  • #40030
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi,
    You can do it from UI by adding the new email template and then the notification rule for the Customer User Entity.

    When creating the notification rule in “Event Name” choose “Create Entity” and in “Recipient list” choose “Owner”.

    #40032

    ramanburdak396
    Participant

    For Now all email are not working .

    Customer also not getting confirmation email , vefore it is working fine.

    Smtp details are using default

    http://prntscr.com/olf46y

    Thanks

    #40033
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    To what version have you upgraded?

    #40034

    ramanburdak396
    Participant

    How i can check version using cli

    I have not updated new version , i’m still using old.

    #40035
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Then you should check the server configuration, email configuration there could be changed to an incorrect one.

    And the application logs at var/logs/prod.log file, there also could be an answer why it doesn’t work anymore.

    #40036

    ramanburdak396
    Participant

    Dev.log file below error msg , but prod.log file not any error regarding email .

    Notified event “console.terminate” to listener “Symfony\Bundle\SwiftmailerBundle\EventListener\EmailSenderListener::onTerminate”.

    #40037
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    It’s not an error and doesn’t relate to an issue. Check the server configuration.
    OR probably an easier solution would be setting the SMTP configuration in UI to the correct one.

    #40039

    ramanburdak396
    Participant

    http://prntscr.com/olg4ix

    Please check screenshot , smtp is correct

    All email not working like order,registration quote etc .

    How i can find why it is not working?

    #40040
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    This is not an application issue if you haven’t upgraded it and the code remains the same.

    If you are recently have done some customization, check them carefully, maybe they broke an email sending.

    Then check your SMTP relay, This message saying that an application can connect to it, but this doesn’t mean it will able to send an email.

    First I recommend checking this setting manually in another application, like any desktop email client.
    Then that email addresses you are sending “to” and “from” are correct and that emails are not in the spam folder or something like that.

    #40041

    ramanburdak396
    Participant

    How i can check default smtp details?

    #40042

    ramanburdak396
    Participant

    Yes , i checked carefully ,Last few days i did not changed code from single file.

    Could i also need to add smtp http://prntscr.com/olgnhq

    #40045
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    You are using the “mail” transport that is not recommended for production use as emails can go to spam with this transport or even be blocked by the email providers. Yes, you should consider to change it to SMTP or investigate why mail doesn’t work, this is on the server configuration side, I don’t have much experience with it to recommend something.

    #40046

    ramanburdak396
    Participant

    Email not sent to only gmail account , other are working fine.

    Why this happens with gmail account?

    Thanks

    #40047

    ramanburdak396
    Participant

    Outgoing mail not working with Gmail account

    #40063
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    I can’t answer that as it can be caused by many factors.

    The most common one is when you have sent to many emails or people marked some of them as SPAM and Gmail banned the website.

    You can check that webserver is not blacklisted with some online services like this one
    http://mail-blacklist-checker.online-domain-tools.com/

Viewing 15 replies - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No