OroCommerce Forums

Covering OroCommerce topics, including community updates and company announcements.

Forums Forums OroCommerce websocket Config problem

This topic contains 1 reply, has 2 voices, and was last updated by Michael Michael 1 year, 1 month ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #38019


    Am trying to configure web socket server deamon within supervisor
    When running ./bin/console gos:websocket:server –env=prod (or dev) , am getting this error
    Could not bind to tcp:// Address already in use
    as am having this setting within parameters.yml :
    websocket_bind_port: 8080
    websocket_frontend_host: ‘*’
    websocket_frontend_port: 8080
    websocket_frontend_path: ‘ws’
    websocket_backend_host: ‘*’
    websocket_backend_port: 8080
    websocket_backend_path: ”

    When executing ./bin/console gos:websocket:server (excluding the envirment option) , it works well.
    As a beginner i don’t understand the problem. any idea?

Viewing 1 replies (of 1 total)
  • Author
  • #38025

    > Could not bind to tcp:// Address already in use

    This usually means, that some other process is already listening on port 8080 on one of the IP interfaces of your machine.

    You can try to provide IP address of a single IP interface (as basically means “attach to all IP interfaces in the system”). If it’s a local installation on your dev machine then I assume would work.

    Alternatively, check what processes already grabbed port 8080. On a Linux machine you can check with lsof – lsof -i :8080

Viewing 1 replies (of 1 total)

The forum ‘OroCommerce’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No