Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Forums OroCRM OroCRM – How do I? Questions Actually change language

This topic contains 11 replies, has 3 voices, and was last updated by Michael Michael 3 years ago.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #28541
    Artem Liubeznyi
    Artem Liubeznyi
    Keymaster

    Hi,

    You have to save these settings and then reload the page (Ctrl-R). The new language will be applied.


    #28542

    ujhgj
    Participant

    Thanks for reply,

    Obviously, I’ve saved the settings and reloaded the page. I even tried incognito window. No luck, interface still English.

    I got latest 1.8.0 version of crm application.

    Also, if it makes a difference, I use Linux Chrome.

    #28543

    ujhgj
    Participant

    no clue?

    #28544
    Artem Liubeznyi
    Artem Liubeznyi
    Keymaster

    Looks like a bug to me. I will invite our QA team to the conversation and we will investigate.

    Can you please provide more details about your setup and environment, apart from using Linux Chrome. The more we know, the easier it would be to reproduce the issue and find out its root cause.

    Thank you in advance.


    #28545

    ujhgj
    Participant

    akovytin@trololo:~$ nginx -V
    nginx version: nginx/1.6.3
    built by gcc 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
    TLS SNI support enabled
    configure arguments: –prefix=/etc/nginx –sbin-path=/usr/sbin/nginx –conf-path=/etc/nginx/nginx.conf –error-log-path=/var/log/nginx/error.log –http-log-path=/var/log/nginx/access.log –pid-path=/var/run/nginx.pid –lock-path=/var/run/nginx.lock –http-client-body-temp-path=/var/cache/nginx/client_temp –http-proxy-temp-path=/var/cache/nginx/proxy_temp –http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp –http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp –http-scgi-temp-path=/var/cache/nginx/scgi_temp –user=nginx –group=nginx –with-http_ssl_module –with-http_realip_module –with-http_addition_module –with-http_sub_module –with-http_dav_module –with-http_flv_module –with-http_mp4_module –with-http_gunzip_module –with-http_gzip_static_module –with-http_random_index_module –with-http_secure_link_module –with-http_stub_status_module –with-http_auth_request_module –with-mail –with-mail_ssl_module –with-file-aio –with-http_spdy_module –with-cc-opt=’-g -O2 -fstack-protector –param=ssp-buffer-size=4 -Wformat -Werror=format-security’ –with-ld-opt=’-Wl,-Bsymbolic-functions -Wl,-z,relro’ –add-module=../nginx-rtmp-module-1.1.7 –add-module=../nginx-push-stream-module-0.4.1 –with-debug
    akovytin@trololo:~$ php -v
    PHP 5.5.9-1ubuntu4.11 (cli) (built: Jul 2 2015 15:23:08)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies
    with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans
    akovytin@trololo:~$ mysql -uroot
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 1769
    Server version: 5.5.44-0ubuntu0.14.04.1-log (Ubuntu)

    phpinfo can be loaded here:
    https://yadi.sk/d/7aBiJx2xj8PdL

    #28546
    Artem Liubeznyi
    Artem Liubeznyi
    Keymaster

    Thank you.

    Our QA team also asked if you could provide the prod.log file, because they still were not able to reproduce this bug.


    #28547

    ujhgj
    Participant

    Here’s oro_install.log: https://yadi.sk/d/yr9S-yJWj8d92
    Here’s dev.log: https://yadi.sk/d/2in4Ig4Wj8dGo
    And prod.log is almost empty:
    [2015-09-13 18:02:19] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHttpException: “No route found for “GET /installer/”” at /home/akovytin/www/crm-application/app/cache/prod/classes.php line 2881 {“exception”:”[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFoundHttpException: No route found for \”GET /installer/\” at /home/akovytin/www/crm-application/app/cache/prod/classes.php:2881, Symfony\\Component\\Routing\\Exception\\ResourceNotFoundException: at /home/akovytin/www/crm-application/app/cache/prod/appProdUrlMatcher.php:8139)”} []
    [2015-09-13 18:02:19] security.DEBUG: Invoked controller “FOS\RestBundle\Controller\ExceptionController::showAction”. (SUB_REQUEST) [] []

    #28548

    ujhgj
    Participant

    Can I have a virtual box with working instance of oro crm, it would be simplier for me to debug issue myself?

    #28549
    Michael
    Michael
    Participant

    Virtual box can be found at this page http://oroinc.com/orocrm/download
    We will investigate your issue and reply asap

    #28550

    ujhgj
    Participant

    Bingo! I got it to work. Although, there is something odd about translation switcher:
    so, after some other barren actions, I’ve downloaded French language, switched to it, and it worked… Then I switched to Russian back again, and it worked too, at last!

    #28551
    Michael
    Michael
    Participant

    Good news. Strange things happens sometimes. Also we found some other issue during investigation of yours)
    Usability of Language switcher will be improved in future.
    Thank you for you patience and for your support.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No
sso for www.magecore.comsso for oroinc.comsso for oroinc.desso for oroinc.frsso for marketplace.orocommerce.comsso for marketplace.orocrm.com