OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – How do I? Questions an email address used by multiple users

This topic contains 8 replies, has 2 voices, and was last updated by  brunpatoch 5 years ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #28507

    brunpatoch
    Participant

    Hello,
    I use the script “php app / console oro: cron: imap-sync –env = prod” to import my messages, everything is ok.
    My problem is that many users use the same email (contact@mondomaine.com). So I added a secondary e-mail to each user mail show email. The trouble is that when I log in with different user, “my account> Mail”, there is only one user who sees the mail import. In the contact cards mails belong to one and only one user.
    Is this normal? If so, is there a way to have an object of type email for multiple users?
    Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #28508
    Artem Liubeznyi
    Artem Liubeznyi
    Spectator

    Hi Patrice,

    Not sure that I have understood your problem correctly. Does your system require multiple user accounts to share the same primary email, or you want to create a “system-wide” mailbox that can be accessed by multiple users simultaneously?

    The former case is not supported yet, as email address should be unique per user and we do not allow users to sync multiple mailboxes yet (though it is planned for the future).

    The latter case will be implemented in our upcoming 1.8 release, where we will change mechanism of email ownership and will allow multi-user access to the same mailbox with an option to create such mailboxes from the UI.

    #28509

    brunpatoch
    Participant

    Hi Artem,
    Thank you for your answer,
    I am having users that share the same secondary address in order to synchronize the same inbox.
    For example several users with a different main address and a common secondary email.
    EX: ( show email + show email ) and ( show email + show email ).
    The mailbox show email can be synchronized for 2 users.

    Does version 1.8 will provide this functionality?
    Thank you

    #28510
    Artem Liubeznyi
    Artem Liubeznyi
    Spectator

    Hi Patrice,

    Yes, if you make show email a system mailbox and allow access to it for two users (or an entire role), they both will be able to see its emails and reply to them.

    Here is a quick guide on how to do it (the well-written user guide is coming soon, too).

    Setting up a mailbox 1

    Setting up a mailbox 2

    Setting up a mailbox 3

    #28511

    brunpatoch
    Participant

    hello,
    @artem thank you for the guide, so I made the update to version 1.7 to 1.8, and then I have created a mailbox shared by several users and then launched my IMAP synchronization. Everything is going well and all users can access email by “my email” link. But in the tab of my activities account emails are not present, is this normal?
    Thank you.

    #28512
    Artem Liubeznyi
    Artem Liubeznyi
    Spectator

    All incoming/outgoing emails are automatically associated (by email address) with Contacts only. To append them to accounts you should add appropriate contexts manually (guide).

    If you are into development you may create a process that will add these contexts automatically according to some rules. Process management is not available from the UI yet.

    This is a nice feature suggestion though, I think we could add this account “recognition” by default in our future version. Thank you for the idea! I will add it to our roadmap.

    #28513

    brunpatoch
    Participant

    Hello @artem
    in an email I try to add a context from the GUI by clicking the “add context” button, the widget opens but I have a javascript error “Failed to load resource: Net :: ERR_EMPTY_RESPONSE”.
    Is there a bug?

    Have you sample code for adding a context?

    Thank you.

    #28514
    Artem Liubeznyi
    Artem Liubeznyi
    Spectator

    Hi Patrice,

    It definitely looks like a bug but we have never encountered such problems with 1.8 branch. Can you please provide more details on your environment and steps that have lead to this error?

    Thank you.

    #28515

    brunpatoch
    Participant

    Hello ,
    I emptied my browser cache, the problem is solved.
    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

The forum ‘OroCRM – How do I? Questions’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No