Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Forums OroCRM OroCRM – How do I? Questions custom role – "You do not have permission to perform this action"

This topic contains 2 replies, has 2 voices, and was last updated by  Sergey Golub 5 months, 1 week ago.

  • Creator
    Topic
  • #29586

    Sergey Golub
    Participant

    Hi,

    I’m study how to create a custom role which can do:

    1. create new Account
    2. create new Opportunity

    Account created – here is all good but then I’m create new Opportunity and try choose that Account, i see: “You do not have permission to perform this action”

    I have locally installed OroCRM Community Edition 2.6.1 and tried the same in on-line demo (Enterprise Edition)

    Setting for Role I used:

    System/User Management/Roles:

    Account [View-Business Unit, Create – BU, Edit – BU, Delete – BU, Assign – BU, Share – BU]
    Opportunity [View-BU, Create – BU, Edit – BU, Delete – BU, Assign – BU, Share – BU]

    i’m edited in local demo role “Sales manager” with upper settings – all work good.
    Think I’m must edit some other options in my custom role but which??

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #29587
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi Sergey,

    There is also a workflow attached to Opportunity entity, and probably new role don’t have permissions to perform transitions on it.
    You can find it on a role edit page at the “Workflows” section, it’s named “Opportunity Management Flow”.

    #29588

    Sergey Golub
    Participant

    Sound strange but:

    System/User Management/Roles/Entity/Searchchecked

    solve my problem.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No
ssossossossossosso