OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – How do I? Questions How to create Lead without Contact

This topic contains 5 replies, has 2 voices, and was last updated by Igor Chornobay Igor Chornobay 5 years, 10 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #28252
    Igor Chornobay
    Igor Chornobay
    Participant

    Hi there,

    When creating a new Lead new Contact will be created automatically based on the Lead information.
    Is it possible to create new Lead without Contact?

    PS: In our workflow Contact for Lead must be created later on the Qualify step for Sales Process.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #28253

    Hi, Igor.

    Contacts are automatically created for Leads with not set Contact relation. This is done only with ‘B2B Sales Process Flow’ workflow when Qualify transition is performed. This workflow is distributed as simple example flow within Sales Bundle. If your workflow is different from current you may create your own workflow for ‘OroCRM\Bundle\SalesBundle\Entity\SalesFunnel’ entity and disable existing one.

    #28254
    Igor Chornobay
    Igor Chornobay
    Participant

    Dmitry,
    Thanks for the reply.

    #28255
    Igor Chornobay
    Igor Chornobay
    Participant

    Dmitry, but Contact for Lead also created when I create new Leat from menu Sales -> Leads -> Create Lead. Can I disable it?

    In this case I don’t use SaleProcess.

    #28256

    Default OroCRM distribution does not contain logic that creates Contact auomatically for Lead, except Sales Flow. Maybe you have some custom logic in Listeners or processes which do this?

    #28257
    Igor Chornobay
    Igor Chornobay
    Participant

    Sorry, Dmitry. My mistake.
    When I tested Process I created process.yml with configuration based on this example. Then I replaced it on my custom config, but forgot disable it.

    Thanks. Now all works fine.

Viewing 5 replies - 1 through 5 (of 5 total)

The forum ‘OroCRM – How do I? Questions’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No