Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Forums OroCRM OroCRM – How do I? Questions how to switch cron off?

This topic contains 7 replies, has 2 voices, and was last updated by Andrey Yatsenko Andrey Yatsenko 4 months, 2 weeks ago.

  • Creator
    Topic
  • #29672

    Adam
    Participant

    Is there any way to switch off all of the cron jobs? I need to debug an import and I can’t because some of the imports are made by cron.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #29673
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    There is no way to disable processing at cron or message consumers, but you can debug it as well.

    Import done in message consumer (oro:message-queue:consume command), not in cron but it’s also a background task, you can debug it almost same way you debug requests from browser.

    I recently recorded video how to debug export. For import it’s very similar, just another async processor used.

    If it’s not help, fill free to ask additional questions.

    #29674

    Adam
    Participant

    I have switched on xdebuger and when I click on the button from the crm and debug my import all is fine. But there is running other import which changes my stuff and I can’t catch this session.

    #29675
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    if you are using PhpStorm for debuging, set “Max. simultanious connections” to 5 and “Force break at first list” than you’ll be able to track all the processes started after you triggered import from UI.

    If you configured supervisor, disable it for a while and run cron and message consumer with xdebug enabled manually, this also will help to set breakpoint inside background processes.

    #29676

    Adam
    Participant

    How can I disable supervisor?

    #29677
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    supervisorctl stop all

    #29678

    Adam
    Participant

    bash: supervisorctl: command not found

    #29679
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    So probably you didn’t configure at all supervisor on application install.
    If you always start message consumer manually it’s not needed.
    The only you need to stop crontab, how to do it depends on your OS , just google for the solution here.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No
sso for www.magecore.comsso for oroinc.comsso for oroinc.desso for oroinc.frsso for marketplace.orocommerce.comsso for marketplace.orocrm.com