OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – HTML, JavaScript, CSS, Design Questions Datagrid:doRefresh problem

This topic contains 1 reply, has 2 voices, and was last updated by Hryhorii Hrebiniuk Hryhorii Hrebiniuk 5 years, 1 month ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #25622

    MSiliunas
    Participant

    Hi,
    Past few days I’ve been trying to figure out what am I doing wrong. The problem is that when I trigger datagrid:doRefresh:my-grid it refreshes but always returns with no data. The datagrid itself is diplayed inside entity edit page (maybe that is the problem?). In other datagrids everything seems to work fine.

    What could be causing this?

Viewing 1 replies (of 1 total)
  • Author
    Replies
  • #25623
    Hryhorii Hrebiniuk
    Hryhorii Hrebiniuk
    Participant

    Hi,

    By

    it refreshes but always returns with no data

    you mean that in Network-tab of browser’s dev-tool the response is empty ({data: []}), or response contains items but grid does not render them?

    What request to you grid access point returns (http://you-host/datagrid/grid-name?….) on refresh action?

Viewing 1 replies (of 1 total)

The forum ‘OroCRM – HTML, JavaScript, CSS, Design Questions’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No