OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums OroCRM OroCRM – Installation/Technical Issues or Problems API documentation gives 500 error

This topic contains 6 replies, has 3 voices, and was last updated by  Dustin 3 weeks ago.

  • Creator
    Topic
  • #39623

    s-andy
    Participant

    Hi, guys!

    When I open /api/doc, I get 500 error. Here is what is written in logs:

    How this can be fixed?

    Thanks.
    Andriy

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #39624
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    It is a known issue introduced by NelmioApiDocBundle.
    As a workaround, you can add to the require section of composer.json at the application lock to the previous version of the dependency by running composer require nelmio/api-doc-bundle:2.13.3
    We are going to fix the compatibility in a further release.
    Internal ticket id #BAP-18979

    #39626

    s-andy
    Participant

    Thanks, Andrey!
    It works now.

    #39822

    Dustin
    Participant

    S-andy, was there anything you did following Andrey’s instructions? I’ve attempted to run the “composer require nelmio/api-doc-bundle:2.13.3” command, and although it keeps saying there is nothing to install or update, and my composer.lock file has the 2.13.3 version listed, I still have yet to be able to access the API Doc, and am still getting the exact fault you originally were getting.

    Any feedback is helpful!

    #39823

    s-andy
    Participant

    Dustin, no, I did not do any special steps (except cache reset, maybe).

    #39824

    Dustin
    Participant

    I’ve tried that as well, figuring maybe the cache may need to be cleared, but still, nothing so I’m sort of lost. I’ll try it again, wonder if it’s processing in dev mode (if at all possible) when I’m running the command

    #39825

    Dustin
    Participant

    Follow Up: Was able to get it working, finally. Not sure what did it (if it was the clearing of the cache again, or if it was the platform update.)

    In either case, I’ve finally got access to the API Doc. Thanks

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No