Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Forums OroCRM OroCRM – Installation/Technical Issues or Problems Can't remove popups on OROCRM login.

This topic contains 8 replies, has 4 voices, and was last updated by  Matej 10 months, 1 week ago.

  • Creator
    Topic
  • #27750

    Matej
    Participant

    Hi,

    Every time I login there are a lot of open popups. Somewhere I saw that I have to enable “autocommit” on DB to resolve my issue. My server admin says that I already have enabled this option.

    Can someone point me in the right direction?

    Thank you.

    It is not a big issue, but kinda annoying one. :)

    Best regards

    Image: http://imgur.com/a/65jiX

    OroCRM 2.1.6 community, Php 7.0.21

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #27751
    dnahrebecki
    dnahrebecki
    Moderator

    Hello @Matej,

    Let’s try to reproduce it. If you work in a way that you have application opened in a couple of browser’s tabs (eg. in one tab you’re responding to customer’s email, in second you are adding tasks, etc.) and then you restart browser and login again, you should be able to see all popups from previous session. Could you please try to reproduce it on your application?

    My results:

    Best Regards,
    Daniel Nahrebecki

    #27752

    Matej
    Participant

    Yes. Actually I see the popups all the time. If I create a task from magento orders view a popup is displayed. Then everytime I load the page all the popups (old and recently created) are shown.

    Please check video here: https://youtu.be/iYBfGIl5xbA

    #27753
    dzakharov
    dzakharov
    Participant

    Hi, Please share log file from app/logs and js console logs if there is.

    #27754

    Matej
    Participant

    Hi,

    Thank you for your assistance.

    Here are the logs and a screenshot from console. Hope it will help.

    Link: https://drive.google.com/drive/folders/0B_R0XzBNexVPamg5ZjgzUlAtX1E?usp=sharing

    Best regards

    #27755

    Matej
    Participant

    Hi,

    Any updates on this?

    Thanks.

    #27756

    Matej
    Participant

    Hi,

    We updated OROCRM to the latest version in a hope this will resolve the issue of popups. But the problem is still here.

    The problem is that we don’t know even how to diagnose the problem. Can somenome point me in the right direction.

    Please check video too see a weird behaviour: https://www.youtube.com/watch?v=B-Lbfvbd8L4&feature=youtu.be

    Thank you

    Our oro Packages:

    oro/redis-config 2.0.0-beta.1 MIT
    oro/doctrine-extensions 1.1.2 MIT
    oro/platform 2.4.2 MIT
    oro/platform-serialised-fields 2.4.0 OSL-3.0
    oro/calendar-bundle 2.4.0 OSL-3.0
    oro/crm-call-bundle 2.4.0 OSL-3.0
    oro/crm-hangouts-call-bundle 2.4.0 OSL-3.0
    oro/marketing 2.4.2 OSL-3.0
    oro/crm-task-bundle 2.4.0 OSL-3.0
    oro/crm 2.4.2 OSL-3.0
    oro/crm-mail-chimp 2.4.2 OSL-3.0
    oro/crm-abandoned-cart 2.4.0 OSL-3.0
    oro/crm-magento-embedded-contact-us 2.4.0 OSL-3.0
    oro/crm-dotmailer 2.4.0 OSL-3.0
    oro/crm-zendesk 2.4.1 OSL-3.0

    #27757
    msulima
    msulima
    Moderator

    Hello, Matej.

    Lets try to find why you can’t close windows.
    As I see in your prod.log you have too many errors like SQLSTATE[HY000]: General error: 2006 MySQL server has gone away. I think something wrong with configuration of yout MySQL service. Please read next article https://dev.mysql.com/doc/refman/5.7/en/gone-away.html, maybe it will be useful.

    Also I see too many errors like “Client error response [status code] 429 [reason phrase] Too Many Requests [url] … [response body] Number of allowed API requests per minute exceeded”.

    But I don’t see any errors that can help me to identify the problem. Can you switch to dev mode on environment with problem and give me response from errored request from your browser?

    And you can check rows in ‘oro_windows_state’ table with field ‘user_id’ equals to identifier of user with that problem.


    #27758

    Matej
    Participant

    Problem solved.

    With the help from a dev we found the cause of the problem in misconfiguration of the NGINX – section which dissalow request of HTTP type DELETE.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No
sso for www.magecore.comsso for oroinc.comsso for oroinc.desso for oroinc.frsso for marketplace.orocommerce.comsso for marketplace.orocrm.com