OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

This topic contains 6 replies, has 2 voices, and was last updated by  dwdonline 6 years, 1 month ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #26154

    dwdonline
    Participant

    Hi,

    I have installed ORO and connected it to Magento 1.9, and everything seems to work fine except one thing.

    I set up an Integration for Magento, and it seems to sync everything except the customers. Here is what I get when I look at the Job Queue. Any pointers would be much appreciated:

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #26155

    Alexandr Smaga
    Participant

    Hello.

    Can you please also post magento logs? have you any customization on magento side ?

    #26156

    dwdonline
    Participant

    Hi,

    I checked the /var/log/ – and there is nothing from this in the files.

    Philip

    #26157

    dwdonline
    Participant

    Hi,

    Yes, I have some extensions installed, but nothing that modifies the customers.

    I checked the /var/log/ – and there is nothing from this in the files.

    Thanks,
    Philip

    #26158

    dwdonline
    Participant

    I just did a little more experimenting.

    With a clean install of Magento 1.9.0.1, I added a customer in the admin. I then connected, and it synced, but no customers. I then imported my database to a clean install of Magento, and it did the same thing. It, marked Finished, but no customer were brought in. I then signed up on the site, then ran the import, and that customer was brought in.

    Here’s what it does when the customers in the database are added in the admin instead of signing up. That’s bad, because then any ordered entered in the admin, the customer will not be brought over:

    #26159

    Alexandr Smaga
    Participant

    Ok, did you select some specific website or “All websites” during integration configuration ? Magento has veryspecific behavior with customers/orders that come from admin panel, so in order to be merge from admin and frontend need to select “All websites”.

    I checked the /var/log/ – and there is nothing from this in the files.

    Are logs enable in System / Config / Developer / Logs setting ?
    All errors should be logged then.

    #26160

    dwdonline
    Participant

    Yes, I chose All Websites.

    As for the logs, yes, they are enabled in the System / Config / Developer / Logs settings. There were other errors there from other issues (which I fixed), but then nothing was added when I run the sync.

    Even when I use a fresh install, it only adds customers that are added after the orocrm plugin has been installed, and that are added by the customer (does not add ones added in the admin).

Viewing 6 replies - 1 through 6 (of 6 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No