OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Dialog Window is kept opening when closing the browser tab

This topic contains 3 replies, has 2 voices, and was last updated by Hiro Hiro 5 years, 4 months ago.

The forum will run in the read-only mode starting from March 1. Please head to StackOverflow for support.

  • Creator
    Topic
  • #26277
    Hiro
    Hiro
    Participant

    I have noticed the modal window is kept opening if I close the browser tab without closing the modal window.

    Example Code:

    How to replicate the issue:

      Open the page having the above code.
      Click the button to open the modal window.
      Close the browser tab (Not the modal window; Don’t close the modal window).
      Open OroCRM dashboard page; The modal window you opened at step 2 is showing up.

    Is there a way to avoid remembering the modal window state?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #26278

    Use stateEnabled dialog widget option for this

    #26279
    Hiro
    Hiro
    Participant

    Thank you for the reply.

    I copied and pasted your code and the issue still occurred.
    I cleared Symfony Cache, but that did not fix the issue as well.

    I searched files using “stateEnabled” option and figured the correct usage is:

    You guys may want to amend the files using “widget” option without using “stateEnabled” option because it is strange that you see the left out dialog next time you open OroCRM just because you forgot to close the dialog.

    Example:

      Open two browser tabs; One of them has OroCRM.
      Go to Customers > Contacts > Select Contact.
      Click “Log Call” button to open the modal window.
      Close the browser tab (Not the modal window or Browser itself; Don’t close the modal window).
      Open OroCRM to see dashboard page; The modal window you left out at step 3 is showing up.

    Thank you!

    #26280
    Hiro
    Hiro
    Participant

    I noticed I put “stateEnabled” option twice. What I meant was:

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No