Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Forums OroCRM OroCRM – Installation/Technical Issues or Problems Error on installing extensions

This topic contains 2 replies, has 2 voices, and was last updated by Mike Kudelya Mike Kudelya 1 year, 10 months ago.

  • Creator
  • #27472



    We want to install some packages but we are experiencing some errors.

    PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 72 bytes) in /var/www/vhosts/domain/test/vendor/composer/composer/src/Composer/DependencyResolver/RuleSetGenerator.php on line 61

    We followed the How to Manage OroPlatform Extensions guide with no result, clearing the cache before the installation and updating composer first and we have 4gb of memory and increased the server timeout.
    We tried to install from browser and command line (package manager and composer ) but the same error appears.

    Any ideas how can we solve this?

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
  • #27473


    We finally achieve to install some extensions, but only 2. When we tried to install a 3rd extension it throws this error:

    root@xxxx:/var/www/vhosts/domain/xxx# php app/console oro:package:install atwix/oro-mandrill dev-master –env=prod
    Do you want to load demo data? (yes/no, default – no) no
    atwix/oro-mandrill requires:
    – oro/platform [installed]
    All missing packages will be installed. Continue? (yes/no) yes
    PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 536870912 bytes) in /var/www/vhosts/domain/xxx/vendor/composer/composer/src/Composer/DependencyResolver/Solver.php on line 220
    Segmentation fault

    We have 6GB of memory right now, so we don’t understand this issue. Also, we tried it with different extensions, but the same error appears.

    Hope you can give us some insight about this.

    Thank you.

    Mike Kudelya
    Mike Kudelya


    Have you tried “composer require atwix/oro-mandrill” ? Which version of composer are you using ? Try to run “composer selfupdate”.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No