OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Install Extensions from Command line?

This topic contains 11 replies, has 2 voices, and was last updated by  Roman Grebenchuk 7 years, 5 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #26432


    Hi there,
    I’m trying to install the oro/crm-zendesk extension through the Package Manager but after clicking the Install button, nothing seems to happen. The spinning wheel just keeps spinning around. I’ve tried a couple of times and have left it for over half an hour each time with no change.

    Is it possible to install extensions from command line?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
  • #26433


    Update here is that I got an Ajax error after about 2 hours.



    On the “Oro Installer” page, the list of Installed Packages is only the Business Application Platform.

    OroCRM is not listed, though that is the application I am coming from. Not sure what’s going on there. I’ve never installed the BAP on its own.

    Therefore, when it asks me to Confirm Installation of oro/crm-zendesk, it seems to indicate that that OroCRM isn’t installed and that it will install it. Probably that’s why it’s taking so long and then maybe timing out.

    Please see below images


    Any help will be greatly appreciated.



    Install from command line

    php app/console oro:package:install –env=prod “oro/crm-zendesk”: “1.*”

    Package Manager timeouts and memory issues will be fixed after migration to latest composer code in nearest releases. As workaround “oro/crm-zendesk”: “1.*” can be added directly to composer.json
    Then run composer update –prefer-dist –no-dev and app/console oro:platform:update –env prod –force
    Also recommend upgrade composer to latest version



    Thanks for the reply.

    When I run php app/console oro:package:install –env=prod “oro/crm-zendesk”: “1.*” I receive the following error “Too many arguments”.

    I changed the code a little to php app/console oro:package:install –env=prod “oro/crm-zendesk”: “1.*” and I am firstly asked whether to load sample data or not. I choose no and then receive the following error: “Cannot find package oro/crm-zendesk: 1.*”

    Do I need to add “oro/crm-zendesk”: “1.*” to composer.json in order to install from command line, or is that a workaround for installing through the browser?

    When I run this command composer update –prefer-dist –no-dev I receive a No command ‘composer’ found.

    My preference is to install everything through command line anyway, so I’m not too worried about getting it working through the browser at this stage.

    Please advise on command line issue.



    Note that the code change I was talking about seems to be related to character set. ie I can’t just copy and paste what you type on this forum, had to replace the quotation marks.


    php app/console oro:package:install -–env=prod oro/crm-zendesk will install latest extension version

    We use Composer for dependency management. It can be installed from . Composer command depends on your system (./composer, ./composer.phar, etc)



    php app/console oro:package:install -–env=prod oro/crm-zendesk returns “The “-?” option does not exist.

    So to install using composer?
    /composer.phar install oro/crm-zendesk (./composer.phar is the command for composer on my system).



    Ok, finally seems as though I’ve got it installed as it appears on the Packages page in Package Manager. I’m following guide from the below link but when I go to the “Manage Integrations” screen I receive “No Integrations available”

    Perhaps it’s not actually installed? Or is there something I need to configure prior to being able to use the integration? This is a freshly installed version of OroCRM 1.5.0.

    Grrrr … I’m sure this should be easier.




    Hi, still no success here.

    In production mode it shows Zendesk in Package Manager as being installed and also is now showing me Zendesk as an integration option. I fill in the details and receive and “500 – Internal Server Error. Site appears to be in maintenance mode” or something along those lines.

    I then tried to setup the interation using app_dev.php in the URL so I can debug the error and there’s no option to choose Zendesk as an integration type. Am I unable to setup the Zendesk Integration in developer mode?

    Again, when trying to install Zendesk via command line using php app/console oro:package:install -–env=prod oro/crm-zendesk I am receiving the following error: “The “-?” option does not exist.



    Sorry, cleared cache in dev folder and now seems to work.

    Receive the following error when in dev mode

    SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘orocrm_zd_url’ in ‘field list’


    Command line app/console runs only in prod or dev mode and simple way to synchronize caches between environments is to delete caches. “Column not found” says what extension is not completely installed. To finish installation run app/console oro:platform:update with force parameter.

Viewing 11 replies - 1 through 11 (of 11 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

Back to top

You will be redirected to [title]. Would you like to continue?

Yes No

You will be redirected to [title]. Would you like to continue?

Yes No