OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

This topic contains 32 replies, has 14 voices, and was last updated by  allxsava 7 years, 8 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #25690


    When installing (./install.sh) I get the following error:
    > purging database

    An exception occurred while executing ‘DELETE FROM orocrm_contact_to_contact_group’:

    SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘oro_crm.orocrm_contact_to_contact_group’ doesn’t exist

    I don’t think it’s created the tables yet.

    Also, every time I run the script, I get a permissions error and I have to fix the perms on the directory

    Unable to create the cache directory (/Users/kimberely/Development/Oro/crm-application/app/cache/dev)

    please help!

Viewing 15 replies - 1 through 15 (of 32 total)
  • Author
  • #25691


    I’m just getting started here, so I’m guessing along with you, but it sounds like your install scripts have been tricked into thinking you’ve already installed the application, and they’re trying to remove it. Maybe your install go stuck half way through? Have you tried removing the oro_crm table manually and re-running the installer?

    If not, the installed is just a wrapper for the build in Symfony console application.

    php app/console doctrine:database:create
    php app/console doctrine:schema:create
    php app/console oro:search:create-index
    php app/console doctrine:fixture:load --no-debug --no-interaction
    php app/console oro:acl:load
    php app/console oro:navigation:init
    php app/console assets:install web
    php app/console assetic:dump

    chmod -R 777 app/cache/
    chmod -R 777 app/logs/

    Can you run each of the php app/console doctrine:database:create lines independently until you find the one that triggers your error? That’ll help track the problem down.


    Yevhen Shyshkin


    It looks like that issue is in database. Could you remove your DB and try installation from the very beginning?

    About permissions: you can try either set correct permissions for cache and log directories, for example:

    or set specific permissions as for Symfony installation http://symfony.com/doc/master/book/installation.html#configuration-and-setup:



    I changed my install.sh by



    I created a new database and ran the install.sh again. I see it installing, creating tables, etc… and then I get a new error

    The source file “/Users/kimberely/Development/Oro/crm-application/app/../web/js/routes.js”
    does not exist.

    And when I goto the URL I just get a blank page.


    Yevhen Shyshkin

    Please, run:

    It will generate routes.js and dump all assetic files.

    As an alternative you can update composer and then dump assetics:



    Thanks, I did this and I still get an internal server error, so I created a new db and ran install.sh again, NO errors but I still get 500 Internal Server Error. I checked the log files in /logs but I don’t see anything relevant (there are lot of logs, I could be missing something).

    How else to trouble shoot this?

    Thanks for your help!



    Re: the logs, the one Server 500 error I got was logged to app/logs/prod.log. Either tail the log

    tail -f app/log/prod.log

    or open it with OS X’s Console.App program

    open app/log/prod.log

    Both these programs will show the log changing in real time. Then, reload the page that triggers the error. You should see the log lines for that request, which should point to the problem.


    Yevhen Shyshkin

    Please, try to remove whole installation (code + DB) and do step by step:
    1) git clone http://gitlab.orocrm.com/crm-application.git
    2) create parameters.yml in app/config
    3) php composer.phar install --prefer-dist (ensure that you have Composer first)
    4) ./install.sh

    Full text is in README.md in the root of repository.



    Hi all,

    I constantly get this error when trying to dump assetics

    Fatal error: Class 'Assetic\Util\PathUtils' not found

    Btw, I’m no Symfony user ;)




    @ja_invica Looks like they may just have fixed this by updating the assetic bundle version

    To get the updated versions run: php composer.phar update –prefer-dist



    Only way I’ve been able to get around the Fatal error: Class 'Assetic\Util\PathUtils' not found issue is by modifying composer.json and specifying the version of the symfony/assetic-bundle package

    I then run php composer.phar upate --prefer-dist followed by install.sh and it works fine.


    Melvyn Sopacua

    Updater friendly, that doesn’t rely on extended attribute tools:
    find app/cache app/logs -type d -exec chmod 777 {} +



    So I was pointed here as I been having issues installing the crm as a package on the platform, I managed to get it installed but now getting a

    PHP Fatal error:Class ‘Oro\Bundle\SegmentationTreeBundle\OroSegmentationTreeBundle’ not found platform-application/app/cache/dev/bundles.php on line 62

    Any will really be appreciated.


    Yevhen Shyshkin

    Hello, max101.

    Look’s like that for some reason you have either outdated cache, or outdated code. SegmentationTreeBundle was removed from code in version 1.0.0.

    To fix cache, please, runphp app/console cache:clear --env prod

    To ensure that your code is not outdated, please, try to find usages of SegmentationTreeBundle all over the code. If you find it – please, update your repository to the latest version, and then clear cache.

    If neither of these recommendations will help – please, post here full stack trace of this exception.



    Hello, I try install crm-app for console its ok, but the web wizard has problems

    see the pic please Install ORO App

Viewing 15 replies - 1 through 15 (of 32 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

Back to top

You will be redirected to [title]. Would you like to continue?

Yes No

You will be redirected to [title]. Would you like to continue?

Yes No