OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

This topic contains 32 replies, has 14 voices, and was last updated by  allxsava 7 years, 2 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #25690

    magentogirl
    Participant

    When installing (./install.sh) I get the following error:
    > purging database

    [Doctrine\DBAL\DBALException]
    An exception occurred while executing ‘DELETE FROM orocrm_contact_to_contact_group’:

    SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘oro_crm.orocrm_contact_to_contact_group’ doesn’t exist

    I don’t think it’s created the tables yet.

    Also, every time I run the script, I get a permissions error and I have to fix the perms on the directory

    RuntimeException]
    Unable to create the cache directory (/Users/kimberely/Development/Oro/crm-application/app/cache/dev)

    please help!

Viewing 15 replies - 16 through 30 (of 32 total)
  • Author
    Replies
  • #25706

    shiraz
    Participant

    Hi,

    I’m getting the below error while running “php composer.phar install –prefer-dist”

    Note: check permissions for app/cache,app/logs,web,app/config/parameters.yml, see http://symfony.com/doc/current/book/installation.html#configuration-and-setup for more

    have tried
    chmod -R 777 app/cache
    chmod -R 777 app/logs
    chmod -R 777 app/config/parameters

    all the requirements have been installed.
    But still getting the error. what I’m i missing?

    http://173.193.228.150/crm-application-master/web/install.php

    #25707

    Sergey
    Participant

    hi @shiraz!

    This notice appears when files inside cache or logs directory owned by apache user and you run command from your user. In this case command can’t handle ownership and you will get this notice.

    I think we can remove this notice and avoid confusing developers in the future. Thanks!

    #25708

    shiraz
    Participant

    Hi sergey,

    Thanks for the reply, but when I try to click on the next button on ( http://173.193.228.150/crm-application-master/web/install.php ) it is giving me a installer notfount error. Could you tell me what is the issue on my configuration. Thanks!

    #25709

    Alexandr Smaga
    Participant

    Hi @shiraz!
    It looks like a rewrite rules issue. Are there mod_rewrite enabled ? Could you please check also is .htaccess enabled in virtual host config.

    #25710

    shiraz
    Participant

    Hi alex,

    Should I enable mod_rewrite could you let me know what all should be enabled on the apache config file.

    Thanks for the help!

    #25711

    shiraz
    Participant

    Hi alex,

    I just had a check on the httpd conf and could see that mod_rewrite is already enabled.

    [root@host-10-0-0-46 ~]# cat /etc/httpd/conf/httpd.conf | grep mod_rewrite
    LoadModule rewrite_module modules/mod_rewrite.so

    So it should be something else I guess! It would be greate if you guys could help me out or guide me through a proper tutorial on installing it on centos, I have already tried most of them on net :(

    Thanks!

    #25712

    shiraz
    Participant

    Hi,

    I have installed it on my server
    ==============================================
    Oro Application has been successfully installed in dev mode.
    To run application in prod mode, please run cache:clear command with –env prod parameter
    ================================================
    now my question is that when i start the clank server it doesn’t start up

    ================================================
    [root@host-10-0-0-46 crm-application-master]# php app/console clank:server –env prod
    Starting Clank
    Launching Ratchet WS Server on: 127.0.0.1:8080
    ================================================

    But it is not starting
    And how can I access it from the front end.
    Thanks

    #25713

    Alexandr Smaga
    Participant

    Hello.

    And how can I access it from the front end.

    Not sure that you question is clear for me, web-socket server needed to push data from server to client.

    There are multipleplaces where it’s used. For example: maintanance mode notifications, reminders, content “outdated” messages etc.

    #25714

    shiraz
    Participant

    Hi,

    The problem is that I have installed it. But is it necessary to startr the clank:server ? when i try to start it the screen just waits with “Launching Ratchet WS Server on: 127.0.0.1:8080” but it doesnt start. So should i do any configuration changes for starting the “Ratchet WS Server”. please guide me as on how can I successfully start using it.

    I have installed it on http://173.193.228.150/crm-application-master/ but how can i access the home page?

    Thanks!

    #25715

    Alexandr Smaga
    Participant

    You have an issue related to web server. Please double check configuration of your web server with our documentation. Also OroCRM based on symfony2 and configuration examples are more or less applicable for it.

    Clank server is some kind of system daemon, so when you run it, it will just wait connection from clients. I think that described behavior is correct. It’s necessary to launch it in order to have features that i mentioned there.

    Anyway you are able to access CRM now using direct link. But we are not able to guarantee that all features will work correctly due to incorrect server configuration.

    #25716

    shiraz
    Participant

    Hi Alex,

    Thank you for explaining this is detail. Everything seems to be working perfectly now, currently im facing just one issue when i try to click on any pages it is showing 404 error. Could you help me out on this.

    Thanks!

    #25717

    Alexandr Smaga
    Participant

    It’s weird. Is this oro 404 page or web server? Could you please do following steps:

      open terminal
      remove all .log files in app/log
      reproduce error
      share log file or error message/stack trace with us
    #25718

    shiraz
    Participant

    Its from the oro 404 page, here is the out put of the log files.

    cat prod.log
    [2014-06-25 15:43:19] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHttpException: “No route found for “GET /ocrm/web/app.php/task”” at /var/www/html/ocrm/app/cache/prod/classes.php line 2255 {“exception”:”[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFoundHttpException: No route found for \”GET /ocrm/web/app.php/task\” at /var/www/html/ocrm/app/cache/prod/classes.php:2255, Symfony\\Component\\Routing\\Exception\\ResourceNotFoundException: at /var/www/html/ocrm/app/cache/prod/appProdUrlMatcher.php:3787)”} []
    [2014-06-25 15:43:19] security.DEBUG: Invoked controller “FOS\RestBundle\Controller\ExceptionController::showAction”. (SUB_REQUEST) [] []
    [2014-06-25 15:43:21] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHttpException: “No route found for “GET /ocrm/web/app.php/task”” at /var/www/html/ocrm/app/cache/prod/classes.php line 2255 {“exception”:”[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFoundHttpException: No route found for \”GET /ocrm/web/app.php/task\” at /var/www/html/ocrm/app/cache/prod/classes.php:2255, Symfony\\Component\\Routing\\Exception\\ResourceNotFoundException: at /var/www/html/ocrm/app/cache/prod/appProdUrlMatcher.php:3787)”} []
    [2014-06-25 15:43:21] security.DEBUG: Invoked controller “FOS\RestBundle\Controller\ExceptionController::showAction”. (SUB_REQUEST) [] []

    #25719

    Alexandr Smaga
    Participant

    Do you have multiple installation under the same document root ?

    #25720

    shiraz
    Participant

    Hello Alex,

    No, but i have installed oro crm on another path. will that be an issue?

Viewing 15 replies - 16 through 30 (of 32 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No