OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Magento Channel correct configuration

This topic contains 13 replies, has 8 voices, and was last updated by  slarkstudio 7 years, 9 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Author
  • #25847



    You should use v2 Magento API, so first URL seems to be correct.
    Did you add this api_user in “System -> Web services -> SOAP/XML-RPC – Users” Magento admin panel and assign this user all necessary roles?

    Let us know if this is the case and you still in trouble.




    yes i do this before i configured the magento channel.
    SOAP/XML-RPC = api_user
    Role Resources = Resource Access (all)



    Possible cases are:
    1. wrong API credentials (username, api key, password or wsdl url), check that you’re able to get this url from your browser and from host where OroCRM installed.
    2. SoapClient unable to parse wsdl
    3. SoapClient unable to perform request or get malformed response
    4. Some chances you have unique case where our system crashed

    Anyway, here’s a patch http://pastebin.com/A3sH7HVb that add logging for this error,
    if you apply this, you will be able to check for “MageCheck error …” message in app/logs/prod.log (or dev.log, depending on your environment).

    Here’s how to apply it:git apply channel-conn-log.patch

    And here’s how to check your potentially big log:cat app/logs/prod.dev | grep MageCheck

    Please provide error log or error message when you do this. Thank you.



    thanks for your feedback.

    i’ve edit the file for the log.

    The the message is unfortunately still “parameters are not valid”

    “app.CRITICAL: MageCheck error: 0: Error cannot find parameter [] []”


    Alexandr Smaga

    Hello Marcus!

    I guess that you are using WS-I mode, in some reasons our integration incompatible with this mode. We are looking for good solution. Please try to disable it in magento(System -> Configuration -> Magento Core API) I will keep you posted.

    Thanks for reporting an issue.



    This is almost identical to the issue I’m getting – can’t get the Magento connector to work.

    I found this in the logs:

    I checked, and WS-I mode is disabled. I can also ran:

    from the command line, and it retrieved what seems to be perfectly well-formed XML.

    I guess it all works via port 80? I’m port-forwarding through my router for this, so there might be an issue there.

    Really keen to hear any ideas!




    Dima Soroka

    Please use SOAP V2 (mydomain.co.uk/api/v2_soap?wsdl=1)



    Staggering on a little – that got past the current issue – now getting:

    I’m using an API ID I set up with all access. I did notice though that deliberately getting the API user and key wrong makes no difference to the error I’m getting. I tried using http://mydomain.com/api.php?type=v2_soap&wsdl=1 so I could rename .htaccess to check that wasn’t messing things up, but again it returned the error above.

    Interestingly, when I used “http://mydomain.com/api.php?type=v2_soap&wsdl=1” in SoapUI and looked at the example “login” call, it seemed to be posting to http://mydomain.com/index.php/?type=v2_soap, and getting HTML back for the home page. Changing this manually to “http://mydomain.com/api.php?type=v2_soap” and posting to that resulted in the error “<faultstring>SOAP-ERROR: Parsing WSDL: Couldn’t load from ‘http://mydomain.com/index.php/?type=v2_soap&wsdl=1’ : Extra content at the end of the document</faultstring>”

    This does seem to come from the WSDL:

    Thanks for any help. I’ve burned many, many hours trying to get this all set up.




    I’m having the same “parameters not valid” issue.

    – Setup the role, user and applied the role to the user
    – Using this for the SOAP URL – http://mydomain.com/index.php/api/v2_soap/?wsdl=1
    – Double checked the username and password
    – WS-I Compliance set to no in System -> Configuration -> Magento Core API

    This is Magento CE Anyone find a solution to this yet?


    Alexandr Smaga

    Hi every one!

    @nvanprooyen could you please share error message from log file in order to find out what happens ?
    @tony7671 it seems for me that your url is not correct it should be http://mydomain.com/index.php/api/v2_soap/?wsdl=1 otherwise url that you tried will be rewritten by webserver to index.php/?type=v2_soap&wsdl=1 because api.php file is not exist.



    Thanks for the quick reply Alexandr. We ended up getting it worked out. It was htaccess denying the connection.



    I met the same issue as above, my site is running on nginx, so how should i do with nginx config?



    First of all (as it’s my first post) I’d like to thank you for OroCRM and OroCRM Bridge!
    I have installed OroCRM, Magento and OroCRM Bridge, OroCRM Tracking plugin also I have created “connection” between them and now can’t work around error like tony7671’s one.

    This is the error I get on “Integrations” page in OroCRM:
    [message] SOAP-ERROR: Parsing WSDL: Couldn’t load from ‘http://646100.nightmar.web.hosting-test.net/index.php/api/v2_soap/index/?wsdl=1’ : failed to load external entity “http://646100.nightmar.web.hosting-test.net/index.php/api/v2_soap/index/?wsdl=1″

    [request] <?xml version=”1.0″ encoding=”UTF-8″?>
    <SOAP-ENV:Envelope xmlns:SOAP-ENV=”http://schemas.xmlsoap.org/soap/envelope/” xmlns:ns1=”urn:Magento” xmlns:xsd=”http://www.w3.org/2001/XMLSchema” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance” xmlns:SOAP-ENC=”http://schemas.xmlsoap.org/soap/encoding/” SOAP-ENV:encodingStyle=”http://schemas.xmlsoap.org/soap/encoding/”><SOAP-ENV:Body><ns1:storeList><sessionId xsi:type=”xsd:string”>4e4b3450cb6a08ed55e796cb2fcdab1d</sessionId></ns1:storeList></SOAP-ENV:Body></SOAP-ENV:Envelope>

    [response] <?xml version=”1.0″ encoding=”UTF-8″?>
    <SOAP-ENV:Envelope xmlns:SOAP-ENV=”http://schemas.xmlsoap.org/soap/envelope/”><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>WSDL</faultcode><faultstring>SOAP-ERROR: Parsing WSDL: Couldn’t load from ‘http://646100.nightmar.web.hosting-test.net/index.php/api/v2_soap/index/?wsdl=1’ : failed to load external entity “http://646100.nightmar.web.hosting-test.net/index.php/api/v2_soap/index/?wsdl=1”

    [code] 500

    I have googled it well and found nothing to help me to fix it.
    Will be glad to get any help.
    P.S. I’m running OroCRM on VPS server, it was very hard for me to configure it and I think server can be a problem. And magento is running or shared hosting.
    P.P.S. Here is screnshot of my error:

Viewing 13 replies - 1 through 13 (of 13 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

Back to top