OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

This topic contains 3 replies, has 2 voices, and was last updated by  Rodolfo 5 years, 10 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #26328

    Rodolfo
    Participant

    Hi,

    My Magento Sync is getting some errors. I tested using Magento CE-1.9.0.1 and Magento EE-1.13.0.0. Both with “Oro Bridge Extension” installed and “active”. Tested using OROCRM 1.4.0-RC1 and today I tested using OROCRM 1.4.0 Stable.

    I’m running the cron job using this command:php app/console oro:cron:integration:sync

    When I did the Integration’s config, the test of the connection passed successfully.

    1) I have more than 1.000 web customers, but after the sync, my orocrm shows only 50 Web Customers;

    2) When the cron tries to get “cart” I always received this message:
    “Oro Bridge extension is not installed” *** Maybe oro extension has compatibility problems with my Magento’s version? So, why I don’t get this error message when the cron gets the customers in the first step?

    3) When the cron tries to retrieve “order” I’ve gotten the same problems of customers. I received only a little of orders.

    So, what do you guys suggest?
    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #26329

    Rodolfo
    Participant

    Solved.
    The problem was [Magento Version] X [Oro Bridge Extension] compatibility.

    #26330

    curata
    Participant

    Hi,
    I’m receiving the same errors. What was the exact nature of the compatibility issue and how did you resolve?

    I’m using Magento 1.9.0.1 and the latest version of the OroCRM bridge which was only released last week.

    Did you actually resolve?

    #26331

    Rodolfo
    Participant

    Hi,

    Try to run using debug mode:

    php app/console oro:cron:integration:sync –integration-id=XX -vvv

    XX is the id number of your channel.

    And then you can check the log files in app/logs/dev.log using maybe:

    tail -f dev.log

    In some old versions of magento you have to remove this lines from your oro-bridge etc/wsdl.xml to become working:
    <!– Fix for magento 1.6.x –>
    <complexType name=”associativeMultiArray”>
    <complexContent>
    <restriction base=”soapenc:Array”>
    <attribute ref=”soapenc:arrayType” wsdl:arrayType=”typens:associativeMultiEntity[]” />
    </restriction>
    </complexContent>
    </complexType>
    <!– // Fix for magento 1.6.x –>

    Also, check if ORO-Bridge is really enable on your magento store. Go to Configuration->Advanced-> and check if ORO Bridge is there, and it is enabled. Sometimes you have to clean magento’s config. cache to enable it.

Viewing 3 replies - 1 through 3 (of 3 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No