OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

This topic contains 18 replies, has 3 voices, and was last updated by  ignat 6 years, 9 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #26857

    pauloasterio
    Participant

    Hello, I want to ship oro-crm with a docker image and integrate it with my CI. The problem is, every time I build the image I have to run the php app/console oro:install which is not suitable because it will drop my current database, is there any way so I can install oro skipping the drop database ??

Viewing 3 replies - 16 through 18 (of 18 total)
  • Author
    Replies
  • #26873

    ignat
    Participant

    It seems like you are using application cache that is not actual for your current code base. Try to remove app/cache/prod and run command app/console cache:clear –env=prod

    #26874

    pauloasterio
    Participant

    The error is gone after cleaning the cache, tks, but the original problem comes back again I see an install page, so I was following Dima’s recomendation :

    “It is possible, just create proper parameters.yml file and warmup cache, you don’t need to run install. Do you have any issues with such flow?”

    this is what I’m trying to accomplish:

    I have an oro install in prod, and now I want to add a node from my codebase, meaning that I do not want to clone the existing install, I want to be able to just plug another oro (with the same config files), skip the oro:install so I don’t drop the database.

    #26875

    ignat
    Participant

    To avoid this error you need to adjust app/config/parameters.yml. When Oro installed parameter “installed” is set too current date. For example https://gist.github.com/ignat-s/b4edfaec1b34a2eb51d8#file-parameters-yml-L23. Consider to put value in this file. Value could be either date time or simply boolean true, like this:

Viewing 3 replies - 16 through 18 (of 18 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

Back to top

You will be redirected to [title]. Would you like to continue?

Yes No

You will be redirected to [title]. Would you like to continue?

Yes No