OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums OroCRM OroCRM – Installation/Technical Issues or Problems [OroCRM 3.1.6] Admin panel – 401 error on api/rest/latest/navigationitems/pinbar

This topic contains 18 replies, has 4 voices, and was last updated by  lsimonin2 1 week, 6 days ago.

  • Creator
    Topic
  • #38938

    lsimonin2
    Participant

    Hi,

    I installed OroCRM in local with docker. All is good I can access to the admin panel, but I got an reload infinitily in cause an 401 Unauthorized error on the url api/rest/latest/navigationitems/pinbar

    Someone can help me ?

    Thank you :)

Viewing 15 replies - 1 through 15 (of 18 total)
  • Author
    Replies
  • #38947
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Hi,

    I can’t reproduce it locally on a clean 2.6, 3.1 and 4.0-beta installation.
    Please set the application URL to the real one at System / Configuration / Application Settings, including the custom port if it exists, clear the browser cookies, clear the application cache and try again.

    Also, the issue can be in the web server configuration.

    If you’ll have the steps to reproduce, please share them with the environment details, we’ll check it.

    Thank you.

    • This reply was modified 4 weeks ago by Andrey Yatsenko Andrey Yatsenko. Reason: removed incorrect link
    #38948

    lsimonin2
    Participant

    Hi,

    Thank you for your reply !
    With my admin user I don’t have the section Websites

    The steps it is I install OroCRM with my custom docker, you can be find here: https://github.com/lucassimonin/orocrm-docker

    And the webserver configuration here: https://github.com/lucassimonin/orocrm-docker/tree/master/docker

    I use https in local may be it’s that the problem ?

    Thank you :)

    #38949
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    Thanks for the link to your Docker container, we will check it.

    I use https in local maybe it’s that the problem ?

    I use https locally as well, with no issues.

    With my admin user I don’t have the section Websites

    Please specify what do you mean by “Websites section” because we have a few website concepts in CRM. You can share the link to the documentation with the description or URL where I can find it.

    #38950

    lsimonin2
    Participant

    Please specify what do you mean by “Websites section” because we have a few website concepts in CRM. You can share the link to the documentation with the description or URL where I can find it.

    In this link that you have shared:

    1. Navigate to the system configuration (click System > Configuration in the main menu).

    2. Select System Configuration > Websites > Routing in the menu to the left.

    But I don’t have this section in OroCRM System section.

    #38951
    Andrey Yatsenko
    Andrey Yatsenko
    Moderator

    My miss, this was the wrong link.
    You can set an application URL at “System / Configuration / Application Settings” section.

    #38953

    lsimonin2
    Participant

    No problem
    I have already the good Application URL

    #38959

    lsimonin2
    Participant

    Any news about the problem ? :)

    Thanks!

    #39033

    lsimonin2
    Participant

    Andrey did you test my docker installation or not yet ?

    thanks

    #39048
    Ilya Antypenko
    Ilya Antypenko
    Participant

    Hi,

    > did you test my docker installation or not yet ?
    Unfortunately I couldn’t test it due to an error: https://github.com/lucassimonin/orocrm-docker/issues/1
    And we are unable to reproduce this error locally as well.

    We will release next patch update 3.1.8 in next few days where we did some changes related to such requests.

    Test this version please and let us know about results.

    Thank you.

    #39052

    lsimonin2
    Participant

    I fixed the problem.

    Ok I wait this version and I will retry.

    Thanks

    #39055

    lsimonin2
    Participant

    I upgrade to 3.1.8 but I have the same error.
    Can you test with my docker ?

    Thanks !

    #39057
    Ilya Antypenko
    Ilya Antypenko
    Participant

    Try to remove 2 lines related to fastcgi_param  HTTPS from the nginx configurations and check again.

    #39063

    lsimonin2
    Participant

    I removed the line in

    docker/nginx/conf/fastcgi.conf
    #fastcgi_param HTTPS on;

    It’s that ? Because I have the same problem:

    General

    Request URL: https://orocrm.local/api/rest/latest/navigationitems/pinbar
    Request Method: GET
    Status Code: 401 Unauthorized
    Remote Address: 127.0.0.1:443

    Response Header:

    Cache-Control: must-revalidate, no-cache, no-store, private
    Connection: keep-alive
    Content-Type: application/json
    Date: Fri, 07 Jun 2019 18:23:59 GMT
    Expires: 0
    Pragma: no-cache
    Server: openresty
    Transfer-Encoding: chunked
    WWW-Authenticate: WSSE realm=”Secured API”, profile=”UsernameToken”
    X-Content-Type-Options: nosniff
    X-Debug-Token: e3bf6e
    X-Debug-Token-Link: https://orocrm.local/_profiler/e3bf6e
    X-Frame-Options: DENY
    X-Powered-By: PHP/7.2.17
    X-XSS-Protection: 1; mode=block

    #39072
    Ilya Antypenko
    Ilya Antypenko
    Participant
    #39076

    lsimonin2
    Participant

    vhost.conf is not used.
    I removed the line in fastcgi.conf and in vhost.conf but if I wait 10sec on the dashboard, the page reload on the pinbar call (information I send before).

Viewing 15 replies - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No