OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems oro:install hangs for long untill it runs out of memory

This topic contains 3 replies, has 2 voices, and was last updated by Andrey Yatsenko Andrey Yatsenko 1 year, 1 month ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #39011

    Dylan
    Participant

    Hello
    I’m trying to install OROCRM Commerce version 3.1 (specifically 3.1.2).
    I followed the steps in the guide (https://oroinc.com/orocrm/doc/2.0/dev-guide/installation) but when I try to run
    bin/console oro:install --env=prod --timeout=99999 the installation process seems to be hanging. I waited for 15 minutes to see if something would happen but after 15 minutes the process had already allocated over 7GB of RAM and proceeded to run out of memory.

    PHP Fatal error: Out of memory (allocated 7958695936) (tried to allocate 4294967304 bytes) in /var/www/html/crm-update/vendor/symfony/symfony/src/Symfony/Component/Intl/Data/Bundle/Reader/BundleEntryReader.php on line 134

    There was no oro_install.log generated or other logs of any kind. I tried running the installation with both PHP 7.2 version and 7.1.30 but both times the result was the same.
    I’m not sure what I’m doing wrong, I have previously sucesfully installed this version of ORO in the same project on different servers or inside a docker container. But for some reason, even though I’m following the same steps as last time, this time something is wrong.
    I would appreciate any help
    thank you for your time

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No