OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Recent Emails Dashboard gets error when logging in by newly created user

This topic contains 2 replies, has 2 voices, and was last updated by  Hiro 8 years, 1 month ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #26161


    I get the following error when I login by the user I newly created:

    An exception has been thrown during the rendering of a template (“Cannot find a field on ‘Oro\Bundle\UserBundle\Entity\User’ that is mapped to column ”. Either the field does not exist or an association exists but it has multiple join columns.”) in OroEmailBundle:Dashboard:recentEmailsGrid.html.twig at line 3.

    I currently commented the line creating the grid at:
    because it was hard for me to extend OroEmailBundle.

    What could it cause this issue?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
  • #26162


    Hello Hiro. I’m having the same error and it started happening after I updated to the latest release (1.3.0). The workaround you posted does work, however if you want to make this modification without actually changing code in the vendor directory, you can override any template like so :

    1. Make a new folder under the app/Resources and name it the Symfony short name version of the bundle (ex: “OroEmailBundle” or “OroCRMSalesBundle”)

    2. Inside that folder you are going to replicate wherever the template’s directory under its view folder of the template you want to override and name the file the same as the original. In this case, my app/Resources folder looks like this:

    3. Copy the entire original file contents to the blank one under the app/ folder and make any modifications you want to in this new file.

    Essentially, this mechanism overrides the default template and instead will use your modified version. The folder & file names must be exact for this to work.

    Hope it helps at least until there’s a fix released.

    ~Coding my life away~



    Hi hemham914,
    I have amended as you suggested and it worked, though I did not do the step 3.
    Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

Back to top

You will be redirected to [title]. Would you like to continue?

Yes No

You will be redirected to [title]. Would you like to continue?

Yes No