OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Request for REST API gives me 403

This topic contains 2 replies, has 3 voices, and was last updated by Hiro Hiro 6 years ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #26230

    I recently have got this situation that I get the following response when I add a new Action to REST API Controller Class:

    Example Action:

    First I thought this issue happens if I add the same action name that I already have used for other Controller Class, but it seems not.

    And where the error message gets generated is at apply() in:

    The issue does not happen if I don’t use “ParamConverter” and just pass the id and get the Entity by coding it.

    Other actions using “ParamConverter” do not get the error but when I add new action it somehow starts returning the error, sometimes.

    I am not sure if we are supposed to use “ParamConverter” within REST API Controller Class as I can see only the following one uses it:


Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
  • #26231

    Yurii Muratov

    Good day.
    Please try to change access level on view permission to your Acme entity.


    Thank you for the reply.

    I think I tried that. I noticed every time I change the permission a new record gets created in the table “acl_classes” so I tried to resolve this issue by having changed all the Entities I made to “System”. And that did not resolve the issue.

    It happens even if I login as the user having the role “Administrator” anyway.

    So far I just stopped using “ParamConverter” for the actions having this issue because any of Oro bundles does seem to use “ParamConverter” for REST API Controller classes except Workflow Bundle (The one under Controller/Api/Rest directory).

Viewing 2 replies - 1 through 2 (of 2 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No