OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Sales Tab gone OroCRM 1.4.0-RC1

This topic contains 2 replies, has 2 voices, and was last updated by Jaimy Jaimy 5 years, 11 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #26293
    Jaimy
    Jaimy
    Participant

    Hi there!

    I’ve noticed a weird situation after installing the 1.4.0-rc1 of OroCRM. Since a few releases the Tab “Sales” with, Opportunities, Leads etc.. have been included in the navigation. After some digging and playing with the new release, I noticed that there was a tab missing, Sales :O.
    So after trying to figure out why it’s not where it supposed to be, like checking my ACL and permissions (I could just go to /opportunity and it gave me a list of opportunities), I started sniffing in the code.

    At first nothing unusual, but it suddenly got to my attention that the whole tab of Sales including the children of the tab (Opportunity, Leads etc..) was set to display:false in the navigation.yml

    Is there a particular reason as why the Sales tab is being set not to display in the navigation menu?
    I look forward to your responds.

    Kind Regards,

    Jaimy Casteleijn

    P.S. If I log in on demo.orocrm.com and login as Administrator (same as I did with my fresh installation) I do see the Sales tab. But if you look closely to the file that is on the github repository, you’ll that it’s display is set to false.
    https://github.com/orocrm/crm/blob/master/src/OroCRM/Bundle/SalesBundle/Resources/config/navigation.yml

    Sales tab set to display:false

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #26294

    Alexandr Smaga
    Participant

    Hello @jaimi!

    As you may notice that relation from particular opportunity/lead were also gone. This tabs were replaced by new per channel sections in account view. So in order to see them you need to make account linked to opportunity through b2b customer. For opportunities that were linked to account till 1.4 automatic migration had to associate them with b2b customers and previous linked accounts.
    Did you migrate from previous version or have fresh install ?

    #26295
    Jaimy
    Jaimy
    Participant

    Hi Alexandr,

    Thanks for your responds. I did a fresh install and after some playing with cleaning the cache and loading the data fixtures manually it seems to be ok again. But it seems that it has something to do with loading the demo datafixtures manually. Since there were other menu items available and the “sales” tab wasn’t at all. I can’t figure out exactly what the problem seems to be. I had to load the datafixtures manually since the installer gave an process time out error upon installing oro.

    Thanks anyways!

    Kind Regards,

    Jaimy Casteleijn

Viewing 2 replies - 1 through 2 (of 2 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No