OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

This topic contains 3 replies, has 2 voices, and was last updated by  Alexandr Smaga 6 years, 4 months ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #26034


    When upgraded from 1.0 to 1.1 I experienced this error.
    Given our server where we deployed orocrm is a micro instance we’ve run into different issues building it.
    The application is fast enough, however installing or upgrading need you to do some workarounds.

    Tracing dependencies for: /home/user/www/domain.com/releases/20140513020329/web/js/oro.min.js

    Then I run in the web folder the following command
    #node bundles/ororequirejs/lib/r.js -o build.js 1>&2
    Tracing dependencies for: /home/user/www/domain/releases/20140513020329/web/js/oro.min.js
    Uglify2 file: /home/user/www/domain.com/releases/20140513020329/web/js/oro.min.js

    Finally, I ended up generating the file on a local machine and uploading to the server, not the ideal way.
    Is there a way to debug this command or any hint where the problem could be happening.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
  • #26035

    Alexandr Smaga


    This command uses nodejs to build minified JS file. Please take a look to linux kernel log (usually it’s /var/log/syslog) to find out why it’s killed.

    I think it’s might be issue in specific version of nodejs (currently I’ve v0.6.12 working) or that was provoked by some linux policy (example: limits of open files, limit IO ops, out-of-memory killer etc..)



    Thanks @asmaga,

    Yes the problem seems that this server runs out of memory, that process consumes all the memory to convert oro.min.js from 3mb to 1.23mb.
    my node version is v0.10.25

    Is there a way to let this process run with a lower memory footprint, probably we’ll move later to a better server, but in the meantime it would nice to solve this problem under this constraint.

    Thanks again,


    Alexandr Smaga

    Hi @raul782.

    Unfortunately I don’t know an answer :( I’will try to figure out how to this could be solved. I will update you.

Viewing 3 replies - 1 through 3 (of 3 total)

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No