OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Installation/Technical Issues or Problems Writing new cache file problem on login

This topic contains 0 replies, has 1 voice, and was last updated by Jaimy Jaimy 7 years ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
  • #25752


    I’m pounding my head on a very weird problem when logging in on OroCrm. At first glance this looks like a permission problem, but it isn’t :< (we have tried to do exactly the same in this folder and we can do it :)). I’m wondering if any of you have faced the same error during the setup of OroCrm? The exception I faced the past few days:request.CRITICAL: Uncaught PHP Exception Twig_Error_Runtime: &quot;An exception has been thrown during the rendering of a template (&quot;Could not write new cache file to app/cache/prod/jms_serializer/Oro-Bundle-NavigationBundle-Title-StoredTitle.cache.php.&quot;) in &quot;OroCRMDashboardBundle:Default:index.html.twig&quot; at line 24.&quot; at app/cache/prod/classes.php line 4748 {&quot;exception&quot;:&quot;[object] (Twig_Error_Runtime: An exception has been thrown during the rendering of a template (\&quot;Could not write new cache file to app/cache/prod/jms_serializer/Oro-Bundle-NavigationBundle-Title-StoredTitle.cache.php.\&quot;) in \&quot;OroCRMDashboardBundle:Default:index.html.twig\&quot; at line 24.

    I found a very nasty work-around, just comment out line 47 in vendor/jms/metadata/src/Metadata/Cache/FileCache.php: throw new \RuntimeException(sprintf('Could not write new cache file to %s.', $path));
    I already made sure that, what’s covered in the topic of Alan Storm, permissions of the app/cache and app/logs are ok. I would like to know if any of you had the same problem and what kind of actions you’ve taken to deal with this issue :)

    Thanks in advance!

The forum ‘OroCRM – Installation/Technical Issues or Problems’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No