OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM OroCRM – Programming Questions Adding attaches as custom field to oro_organization doesn't work for image field

This topic contains 3 replies, has 2 voices, and was last updated by alendo alendo 5 years ago.

The forum will run in the read-only mode starting from March 1. Please head to StackOverflow for support.

  • Creator
    Topic
  • #24976
    alendo
    alendo
    Participant

    I created a migration to add some fields to oro_organization:

    After migration I can see the new fields in organization form, but not the file field.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #24977
    alendo
    alendo
    Participant

    is there anyone who can help me?
    thanks

    #24978

    Yurii Muratov
    Participant

    Hi.

    In your example, logo field relation will be created as System field.
    You can go to the Organization entity config page in UI. Logo field will be exusts and it will be System. That is why this field does not add automatically to the view and edit pages.

    To create logo field as Custom field, You should add additional parameters to the 4th parameter of addImageRelation:

    In this case, this field will be Custom and will be automatically added to view and edit pages.

    #24979
    alendo
    alendo
    Participant

    It works.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No