OroCRM Forums

Covering OroCRM topics, including community updates and company announcements.

Forums Forums OroCRM Got stuck with OROCrm installation. Please help.

This topic contains 3 replies, has 3 voices, and was last updated by  annuksun 5 years, 1 month ago.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

  • Creator
    Topic
  • #30203

    annuksun
    Participant

    Hi everyone,
    Please help with the installation of OROCrm. I should say that I’m not a very technical person so I’m just following the manual published at this website.
    At this moment, I’ve faced the same issue that steffen.bauer published on 6th of June.
    – Installing zendframework/zend-stdlib (2.1.5)
    Downloading: Connecting… Failed to download zendframework/zend-stdlib from dist: The “https://api.github.com/repos/zendframework/Component_ZendStdlib/zipball/1b21f3f9a206bd79da3c660b8c550b50d88f3a7e” file could not be downloaded (HTTP/1.1 404 Not Found)

    I’ve tried to use composer update –no-dev instead of composer install. However, I’m not sure wether that command work correctly. The output was
    root@alyaka-orocrm:/var/www/orocrm# composer update –no-dev
    Loading composer repositories with package information
    Updating dependencies
    Killed

    Anyway, an installation guide says that when composer install finishes its job, I should see an invitation to set up parameters.yml file. I was not invited to do that when composer update finished working.
    When I used the following command:
    php app/console doctrine:database:create
    the result was
    root@alyaka-orocrm:/var/www/orocrm# php app/console doctrine:database:create
    PHP Warning: require_once(/var/www/orocrm/app/bootstrap.php.cache): failed to open stream: No such file or directory in /var/www/orocrm/app/console on line 10
    PHP Fatal error: require_once(): Failed opening required ‘/var/www/orocrm/app/bootstrap.php.cache’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/orocrm/app/console on line 10

    As I understand, this bootstrap file should be generated by the composer. So the question is what should I now? How to fix this? Please help.
    Thanks a lot in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #30204

    Rodolfo
    Participant

    I believe your php are running out of memory.

    Try this:
    php -d memory_limit=-1 composer.phar install

    This shows how much is your current memory_limit:
    php -i | grep memory_limit

    I hope this can help. If you have less than 512M I really recommend to update your php.ini with a higher value.

    #30205
    kevando
    kevando
    Participant

    Thank you Rodolfo. That solution worked for me.

    #30206

    annuksun
    Participant

    Hi Rodolfo,

    Thank you for your reply.
    I’ve checked memory settings – that’s the output.

    root@orocrm:~# php -i | grep memory_limit
    memory_limit => -1 => -1

    If I understand this correctly, the memory setting is the same as you advised in your previous command:
    php -d memory_limit=-1 composer.phar install

    So what else I could do/try?

    Big thanks everyone for the support!

Viewing 3 replies - 1 through 3 (of 3 total)

The forum ‘OroCRM’ is closed to new topics and replies.

You will be redirected to [title]. Would you like to continue?

Yes No