Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

Forum Replies Created

Viewing 15 replies - 1 through 15 (of 41 total)
  • Author
    Replies
  • in reply to: Datagrid – Join to Non-related Entity #34257

    archy_bold
    Participant

    Ha, I’m an idiot! Thanks for the help. It worked.

    in reply to: Marketing List Not Synchronizing With MailChimp #27226

    archy_bold
    Participant

    I got v1.4.2 of the MailChimp bundle working with 1.8.2 of OroCRM, the newer bundles worked in OroCRM 1.9.6. The main issue I had was that the marketing list type was set to ‘On demand’ rather than ‘Dyanmic’ and on demand marketing lists don’t synchronize. This isn’t mentioned in the documentation, however, and I had to find it in the code.

    in reply to: Marketing Lists – Columns From Related Entities #28988

    archy_bold
    Participant

    Cool, thanks for clearing it up. I’m sure we’ll have some use cases for this stuff.

    in reply to: Marketing Lists – Columns From Related Entities #28986

    archy_bold
    Participant

    Thanks for letting me know Artem.

    I’m struggling to see how the feature would be useful for anything other than getting reports into the CRM in that case, it certainly doesn’t seem like we can launch campaigns from the CRM. Or is that the point of the marketing lists in Oro? Purely to get marketing statistics alongside customer information for reporting?

    in reply to: Marketing List Not Synchronizing With MailChimp #27224

    archy_bold
    Participant

    Seems like the final piece of the puzzle was that the mailing list needed to be set up as a ‘Dynamic’ type. This is not clear from the documentation.

    Anyway, it seems to – finally – be creating and updating segments MailChimp now.

    in reply to: Marketing List Not Synchronizing With MailChimp #27223

    archy_bold
    Participant

    I did notice there was an incompatibility between OroCRM 1.8.2 and the MailChimp bundle 1.4.4 as the oro:cron:mailchimp:export command was throwing an exception of:

    Regressing to 1.4.2 has fixed the error but it’s still not working.

    I’ve also tried upgrading to OroCRM 1.9.6 and 1.5.4 of the MailChimp bundle and it’s not working. What have I done wrong here?

    in reply to: Marketing List Not Synchronizing With MailChimp #27222

    archy_bold
    Participant

    Am I asking this in the right place?

    in reply to: Functional Testing Views/Forms #34237

    archy_bold
    Participant

    Thanks for the response. I think I did run cache:clear first but it didn’t help. I’ll look out for JS errors next time.

    in reply to: Functional Testing Views/Forms #34235

    archy_bold
    Participant

    So I managed to get this working by completely clearing out my test cache and database and reinstalling everything again. Is there a command I can run to clean the install, should I be running app/console oro:platform:update --env=test after every code change?

    in reply to: Package Install on Production Environment #25224

    archy_bold
    Participant

    We managed to get it working with composer. Is that the best way?

    in reply to: Testing Processes #34174

    archy_bold
    Participant

    I’ve considered running the oro:process:execute:job command in a functional test, but I don’t really know the best way to get the process job IDs that are relevant.

    in reply to: Package Install on Production Environment #25222

    archy_bold
    Participant

    [Wrong thread!]

    in reply to: Datagrid Choice Filter Contains/With Wildcard #34172

    archy_bold
    Participant

    Brilliant! It works with a couple of modifications to SelectLikeFilter. Just with an extra use for FilterUtility and with wildcards round the $value when setting the query parameter. Thanks!

    in reply to: Import – Clear Old Data #34145

    archy_bold
    Participant

    Great to hear you sorted. batch_jobs.yml is for automated importing rather than through a button.

    in reply to: Functional Tests 401 #33764

    archy_bold
    Participant

    Interestingly, this only happened to me in a method that was used as a @dataProvider. When I moved the code out, into the test case itself, the error was gone.

    Was that the same issue as the initial one?

Viewing 15 replies - 1 through 15 (of 41 total)
Back to top

You will be redirected to [title]. Would you like to continue?

Yes No

You will be redirected to [title]. Would you like to continue?

Yes No