Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

Forum Replies Created

Viewing 15 replies - 1 through 15 (of 16 total)
  • Author
    Replies

  • KnutFr
    Participant

    Anyone with the same issue ?

    Thanks
    Adrien


    KnutFr
    Participant

    Hi,
    I use a docker container reverse-proxy : https://github.com/jwilder/nginx-proxy
    and this container : https://github.com/JrCs/docker-letsencrypt-nginx-proxy-companion to enable SSL with let’s encrypt
    and I add environments parameters to my crm container to set the SSL (VIRTUAL_HOST, LETSENCRYPT_HOST & LETSENCRYPT_EMAIL).

    Thanks

    Adrien


    KnutFr
    Participant

    Here more information :

    This issue can be reproduce with any forms contained in modal. For example i have exactly the same issue when i’m trying to mail someone from his profil :

    Crash on mail

    However, when I try to directly access the form url (on HTTPS mode), it works great (idem for adding a language, access directly by url works…) but with basic access, “Widgets loading failed” each time.

    Regards,
    Adrien STEFANSKI

    in reply to: Create custom entity from Rest API #28973

    KnutFr
    Participant

    Hi,

    Thanks for your reply. I’m already using this API for existing Oro entity, but I don’t understand how to exaclty use it to create my own entity. (What I would exactly like to do is create a custom lead entity processed by an external existing software. For testing I have already try to create “Lead” record via OroAPI and it works great ! )

    My issue is specific to my own created custom entity.

    Does it work the same way ?

    Thanks.

    in reply to: Create custom entity from Rest API #28971

    KnutFr
    Participant

    Hi Mike,

    What I would like to do is exactly what you can do on this link : url/entity/extend/entity/create but I would like to be able to do this via an API call. Also I would like to update / Delete custom entity structure.

    Obviously I also want to create generic call for Create / Read / Update & Delete single record of custom entity.

    For example:

    Is there some existing call that can do things like that ?

    Thanks.

    in reply to: Create custom entity from Rest API #28969

    KnutFr
    Participant

    Hi, is there an update about this point with last version of orocrm ?

    Thanks, KnutFr

    in reply to: Create custom entity from Rest API #28967

    KnutFr
    Participant

    Hi,

    I would like to be able to create custom entity table, and also create records obviously.

    Thanks again,
    KnutFr

    in reply to: Programmatically send email from template #28954

    KnutFr
    Participant

    Hello,

    Not exactly. What I would like to do is to send an email from a custom controller, passing template name, contact and entity as parameters.

    For example :

    in reply to: Use Email template as services #28707

    KnutFr
    Participant

    I haven’t found a solution yet, but how can I send a template mail to a Contact entity in a controler ? (email template is based on Oro Contact Entity).

    For example, I have my $contact and my $template returned by Doctrine Entity Manager, there is a way to send it?

    Thanks a lot,
    KnutFr

    in reply to: Use Email template as services #28704

    KnutFr
    Participant

    There’s nothing on my log and also nothing in my system mail log …

    Maybe a mistake in my “actions_configuration” syntax ?

    in reply to: Use Email template as services #28702

    KnutFr
    Participant

    Hi,

    Yes it’s always running but my job is a process and doesn’t appear in job queue.
    Is there any logs for process ?

    in reply to: Use Email template as services #28700

    KnutFr
    Participant

    Hi,

    I have another problem, I have a job which have to send mail to contact when his seniority is updated (every year) but nothing is sended (process execution is successful anyway).

    My process.yml:

    Everything is set, my mail template, my contact entity.
    Am I doing something wrong ?

    KnutFr

    in reply to: Add specific API call (GET) on WorkFlow #28586

    KnutFr
    Participant

    The problem was my code, in fact in my process I modified the field without Entity Manager, when I’m using it everything works fine !

    Again thank you a lot !

    in reply to: Add specific API call (GET) on WorkFlow #28584

    KnutFr
    Participant

    Hi,

    Just asking a final question and I think that my process will be complete !
    I have a cron call (oro:cron:checkprocess) which alter some record on a custom entity.
    I have also created a process, triggered on update on those records (from custom entity) but when my cron job is executed and DB alterated, the trigger doesn’t launch my process.

    Am I doing something wrong ?
    Is it possible to directly call a process at the end of execute() cron job method ?

    Again thanks a lot !
    KnutFr

    in reply to: Add specific API call (GET) on WorkFlow #28582

    KnutFr
    Participant

    Hi,

    I have implemented a process which sending some mail from defined template :

    But when this process is executed, i have the following error message:

    Do I have forget something in my action declaration ?
    Maybe something is missing in template owner’s profile ?

    Thanks a lot,
    KnutFr

Viewing 15 replies - 1 through 15 (of 16 total)

You will be redirected to [title]. Would you like to continue?

Yes No