Forums

Covering OroCommerce, OroCRM, OroPlatform topics, including community updates and company announcements.

Starting from March 1, 2020 the forum has been switched to the read-only mode. Please head to StackOverflow for support.

Forum Replies Created

Viewing 15 replies - 16 through 30 (of 31 total)
  • Author
    Replies
  • in reply to: Price XXX #39910

    peeush
    Participant

    Perfect – thanks Michael! I changed “English” (in Formatting column) to “English (United Kingdom)” and it solves the issue!

    THank you for your guidance!

    in reply to: How to configure Flat Rate shipping option? #39908

    peeush
    Participant

    Thank you Michael – it’s my bad; I had been looking in System-.Configuration->Integrations so far and could not see “Manage Integrations” option there; I have found the right option now!

    Thank you for your prompt reply!

    in reply to: Price XXX #39899

    peeush
    Participant

    Hello – I am having the same issue (pricing shows XXX in front of the price), even though I have updated Localization settings in my Admin App – below are the settings I am using:

    System / Configuration / Localization
    Location options
    Primary Location*: India

    Localization settings
    Default Localization*: English
    Enabled Localizations*: English

    Please advise on how to fix this.

    in reply to: Create new frontend theme from scratch #39759

    peeush
    Participant

    Hi Andrey – seems like this is the file I was looking for:
    https://github.com/oroinc/platform/blob/master/src/Oro/Bundle/UIBundle/Resources/views/layouts/blank/page/layout.yml

    Will try this now and come back to you on this thread if I get stuck again.

    in reply to: Create new frontend theme from scratch #39757

    peeush
    Participant

    Thank you Andrey! As it happens, I have gone through the documentation on Storefront UI section of a Developer’ Documentation and mostly understand theming\layout updates – I am able to make minor changes to some parts of the website. I am, however, struggling with a proper place to start revamping my home page and create templates for other pages.

    Can you please point me to the layout definition of blank theme? I can then start referring to the page structure (layout elements) on each page and start extending them.

    Many thanks!

    in reply to: Create new frontend theme from scratch #39753

    peeush
    Participant

    Thanks Andrey! I’ll use blank theme for developing my customised theme. I have a few questions though:

    • I see in the “Advanced Layout Implementation Example” documentation (https://oroinc.com/b2b-ecommerce/doc/current/dev-guide/other/layouts/layout-implementation-example#dev-cookbook-layouts-implementation-example) the same pattern – adding a new tree in layout.yml i.e. seems to be creating the page layout from scratch – when is this to be used?
    • Where can I find the equivalent of default.yml file for blank theme – so I can find out which items to remove/move?
    • Where can I find the equivalent of default.html.twig file for blank theme – so I can base my template on it?
    • How can I replace the out-of-the-box versions of bootstrap and jquery files?
    • I could not get assets.yml file working – it adds the files in the output section correctly to the header, but my css (or js files) that I gave in input section to be combined and created as the output file – did I misunderstand this?

      Thanks again for your help!

    in reply to: Recreate server from backup #39652

    peeush
    Participant

    Thank you for guiding me in the right direction Andrey! I will try out the steps you have outlined and will reach out if I am still running into issues.

    in reply to: Supplier/Vendor interface? #39116

    peeush
    Participant

    Thanks Ilya!

    I will continue to explore further; multiple organisations is not the same as multi-seller/supplier paradigm where at the bare minimum, there’s facility for sellers/suppliers to sign-up on the website (pending approval from admin) and login to manage their products (and, if possible, sales). All sellers/suppliers products are still sold through the same website though.

    At this point in time, I am primarily interested in community edition; will reach out to your sales team if I need to move to Enterprise edition.

    Regards
    Peeush

    • This reply was modified 3 years, 3 months ago by  peeush.
    in reply to: Supplier/Vendor interface? #39113

    peeush
    Participant

    Thanks Ilya!

    I have had a good look through all the features listed in the OroCommerce Enterprise Edition as well, but there’s still no Supplier/Vendor interface or features to turn it into a multi-vendor marketplace. For example, there’s no separate registration screens for sellers/suppliers, no user type “sellers/suppliers”, not possible for such a user to create and update their own products (but not have access to any other seller/supplier’s products) etc, no portal where such sellers/suppliers can login and see their products, inventory, RFQs…

    Any ideas on how to do it without going for a massive code customisation?

    Thanks
    Peeush

    in reply to: How to take backup of and restore an OroCRM installation? #28455

    peeush
    Participant

    Thanks Dima!

    I was trying to move the DB from one environment to other, but was making the mistake of using the latest version of OroCRM on the new server.

    As you noted, I have now tried upgrading the current server (using the instructions in upgrade.md) prior to moving the DB to the new environment, however, upgrade is failing at the last step with the following error:

    PHP Fatal error: Uncaught exception ‘ReflectionException’ with message ‘Class Oro\Bundle\UserBundle\Entity\AbstractUser does not exist’ in /usr/share/nginx/html/orocrm/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/Tools/GeneratorExtensions/ExtendEntityGeneratorExtension.php:58
    Stack trace:
    #0 /usr/share/nginx/html/orocrm/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/Tools/GeneratorExtensions/ExtendEntityGeneratorExtension.php(58): ReflectionClass->__construct(‘Oro\\Bundle\\User…’)
    #1 /usr/share/nginx/html/orocrm/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/Tools/GeneratorExtensions/ExtendEntityGeneratorExtension.php(40): Oro\Bundle\EntityExtendBundle\Tools\GeneratorExtensions\ExtendEntityGeneratorExtension->generateConstructor(Array, Object(CG\Generator\PhpClass))
    #2 /usr/share/nginx/html/orocrm/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/Tools/EntityGenerator.php(85): Oro\Bundle\EntityExtendBundle\Tools\GeneratorExtensions\ExtendEntityGeneratorExtension->generate(Array, Object(CG\Generato in /usr/share/nginx/html/orocrm/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/Tools/GeneratorExtensions/ExtendEntityGeneratorExtension.php on line 58

    So you know, I have a few many-to-many (and other types of) custom entity relationships with other custom entities (created from the UI) and system entities in the current system.

    Any ideas how to fix this?

    Thanks!

    in reply to: Unable to create entity field for custom entity #35193

    peeush
    Participant

    Hi Ivan – thank-you for looking into this and sorry, I did not get back to working on it any earlier.

    To answer your questions:
    I installed the master branch from github.
    Yes, there are a few many-to-many (and other types of) custom entity relationships with other custom entities (created from the UI) and system entities.

    I have also tried taking a backup of the database, making a fresh install of v1.7.5 on a new application server, and restoring the database (after cache clear) – hoping it will fix the issue, but now I am not even able to log in (am getting error: “Oro\Bundle\UserBundle\Entity\User::$avatar does not exist”).

    Any ideas on what to do next?

    Thanks

    in reply to: How to take backup of and restore an OroCRM installation? #28453

    peeush
    Participant

    Thanks Dima; sorry I wasn’t able to get back to trying this out earlier.

    I tried your suggested method but with no success. Below is what I did:
    1. Took a database backup (from mysql command line)
    2. Installed a completely clean instance of OroCRM – v1.7.5 with a blank database.
    3. From mysql command-line, I restored the database from the backup I took in step 1.
    4. Cleared cache on the newly installed orocrm application.
    5. Tried to log in, but am getting an error: “Oro\Bundle\UserBundle\Entity\User::$avatar does not exist”.

    So you know, in my system, I had created some new entities (with many-to-many, many-to-one and one-to-many relationship with other custom and system entities.

    Any ideas on what I am doing wrong or how to go about restoring my system?

    Thanks


    peeush
    Participant

    Hi

    I am struggling with the same issue, but running “app/console oro:entity-config:update –force” command throws the following error:

    [ReflectionException]
    Property OroCRM\Bundle\SalesBundle\Entity\Opportunity::$trainingClasses does not exist

    Essentially, this command does not run because of the same issue i.e. missing model!

    Please advise!

    Thanks!

    in reply to: Unable to create entity field for custom entity #26565

    peeush
    Participant

    Update: Found the following errors in app/logs/prod.log:

    [2015-06-25 03:12:01] security.DEBUG: ACL found, permission granted. Voting to grant access [] []
    [2015-06-25 03:12:01] request.CRITICAL: Uncaught PHP Exception Oro\Bundle\EntityConfigBundle\Exception\RuntimeException:
    “A model for “Extend\Entity\Trainer::trainingclass_altTrainers” was not found” at /usr/share/nginx/html/orocrm/vendor/oro/platform/src/Oro/Bundle/EntityConfigBundle/Config/ConfigModelManager.php line 223 {“exception”:”[object] (Oro\\Bundle
    \\EntityConfigBundle\\Exception\\RuntimeException: A model for \”Extend\\Entity\\Trainer::trainingclass_altTrainers\” was not found at /usr/share/nginx/html/orocrm/vendor/oro/platform/src/Oro/Bundle/EntityConfigBundle/Config/ConfigModelMana
    ger.php:223)”} []
    [2015-06-25 03:12:01] security.DEBUG: Invoked controller “FOS\RestBundle\Controller\ExceptionController::showAction”. (SUB_REQUEST) [] []

    Looks like one of the entity fields that I created and subsequently amended, is corrupt now. Is there any way to get this reconfigured?

    Thanks!

    in reply to: PDOException error after install on CentOS 7 #26395

    peeush
    Participant

    Thanks for pointing me in the right direction Dmitry! It’s working now :-)

    The issue was because of incorrect SELinux settings on my web/app server; for any others users who may run into this issue – setting correct SELinux permissions for network connect resolved the issue for me:

    sudo setsebool -P httpd_can_network_connect_db 1
    sudo setsebool -P httpd_can_network_memcache 1

Viewing 15 replies - 16 through 30 (of 31 total)
Back to top

You will be redirected to [title]. Would you like to continue?

Yes No

You will be redirected to [title]. Would you like to continue?

Yes No